BSplineCurve3dH Class

Weighted (Homogeneous) BSplineCurve in 3d

Extends

Methods

Name Description
clone(): BSplineCurve3dH Return a deep clone of this curve.  
computeAndAttachRecursiveStrokeCounts(options?: StrokeOptions, parentStrokeMap?: StrokeCountMap): void Compute individual segment stroke counts.  
computeStrokeCountForOptions(options?: StrokeOptions): number Assess length and turn to determine a stroke count.  
copyPoints(): any[] Return a simple array of arrays with the control points as [[x,y,z,w],[x,y,z,w],..]  
copyPointsFloat64Array(): Float64Array Return a simple array of the control points coordinates  
copyWeightsFloat64Array(): Float64Array    
copyXYZFloat64Array(deweighted: boolean): Float64Array Return a simple array of the control points xyz coordinates.  
dispatchToGeometryHandler(handler: GeometryHandler): any Second step of double dispatch: call handler.handleBSplineCurve3dH(this)  
emitStrokableParts(handler: IStrokeHandler, options?: StrokeOptions): void call a handler with interval data for stroking.  
emitStrokes(dest: LineString3d, options?: StrokeOptions): void Append stroked approximation of this curve to the linestring.  
evaluatePointAndDerivativeInSpan(spanIndex: number, spanFraction: number, result?: Ray3d): Ray3d Evaluate at a position given by fractional position within a span.  
evaluatePointInSpan(spanIndex: number, spanFraction: number, result?: Point3d): Point3d Evaluate at a position given by fractional position within a span.  
extendRange(rangeToExtend: Range3d, transform?: Transform): void Extend a range so in includes the range of this curve  
getPolePoint3d(poleIndex: number, result?: Point3d): undefined | Point3d Get a pole, normalized to Point3d.  
getPolePoint4d(poleIndex: number, result?: Point4d): undefined | Point4d Get a pole as Point4d  
getSaturatedBezierSpan3dH(spanIndex: number, result?: BezierCurveBase): undefined | BezierCurveBase Return a CurvePrimitive (which is a BezierCurve3dH) for a specified span of this curve.  
getSaturatedBezierSpan3dOr3dH(spanIndex: number, _prefer3dH: boolean, result?: BezierCurveBase): undefined | BezierCurveBase Return a BezierCurveBase for this curve.  
isAlmostEqual(other: any): boolean test if the curve is almost equal to other  
isInPlane(plane: Plane3dByOriginAndUnitNormal): boolean Test if the curve is entirely within a plane.  
isSameGeometryClass(other: any): boolean Test if other is an instance of BSplineCurve3dH  
knotToPoint(u: number, result?: Point3d): Point3d Evaluate at a position given by a knot value.  
knotToPointAnd2Derivatives(u: number, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors Evaluate at a position given by a knot value.  
knotToPointAndDerivative(u: number, result?: Ray3d): Ray3d Evaluate at a position given by a knot value.  
quickLength(): number Return the control polygon length as quick approximation to the curve length.  
spanFractionToKnot(span: number, localFraction: number): number map a spanIndex and fraction to a knot value.  
tryTransformInPlace(transform: Transform): boolean Apply transform to the curve  
assemblePackedXYZW(controlPoints: Float64Array | number[][] | Point3d[] | Point4d[] | { weights: Float64Array, xyz: Float64Array }): undefined | Float64Array Static Assemble a variously structured control points into packed array of [xyzw].  
create(controlPointData: Float64Array | number[][] | Point3d[] | Point4d[] | { weights: Float64Array, xyz: Float64Array }, knotArray: Float64Array | number[], order: number): undefined | BSplineCurve3dH Static Create a bspline with given knots.  
createPeriodicUniformKnots(poles: Float64Array | Point3d[] | Point4d[], order: number): undefined | BSplineCurve3dH Static Create a smoothly closed homogeneous B-spline curve with uniform knots.  
createUniformKnots(controlPoints: Float64Array | Point3d[] | Point4d[], order: number): undefined | BSplineCurve3dH Static Create a homogeneous B-spline curve with uniform knots.  

Inherited methods

Name Inherited from Description
addMappedStrokesToLineString3D(map: StrokeCountMap, linestring: LineString3d): number Inherited BSplineCurve3dBase Evaluate strokes at fractions indicated in a StrokeCountMap.
announceClipIntervals(_clipper: Clipper, _announce?: AnnounceNumberNumberCurvePrimitive): boolean Inherited BSplineCurve3dBase Find intervals of this curvePrimitive that are interior to a clipper
appendPlaneIntersectionPoints(plane: PlaneAltitudeEvaluator, result: CurveLocationDetail[]): number Inherited BSplineCurve3dBase Implement CurvePrimitive.appendPlaneIntersections
clonePartialCurve(fractionA: number, fractionB: number): BSplineCurve3dBase Inherited BSplineCurve3dBase Return a curve primitive which is a portion of this curve.
cloneTransformed(transform: Transform): BSplineCurve3dBase Inherited BSplineCurve3dBase Return a transformed deep clone.
closestPoint(spacePoint: Point3d, _extend: VariantCurveExtendParameter, result?: CurveLocationDetail): undefined | CurveLocationDetail Inherited BSplineCurve3dBase Search for the curve point that is closest to the spacePoint.
collectBezierSpans(prefer3dH: boolean): BezierCurveBase[] Inherited BSplineCurve3dBase Return an array with this curve's bezier fragments.
collectCurvePrimitives(collectorArray?: CurvePrimitive[], smallestPossiblePrimitives: booleanfalse, explodeLinestrings: booleanfalse): CurvePrimitive[] Inherited BSplineCurve3dBase Return an array containing only the curve primitives.
collectCurvePrimitivesGo(collectorArray: CurvePrimitive[], _smallestPossiblePrimitives: boolean, _explodeLinestrings: booleanfalse): void Inherited BSplineCurve3dBase Return an array containing only the curve primitives.
constructOffsetXY(offsetDistanceOrOptions: number | OffsetOptions): undefined | CurvePrimitive | CurvePrimitive[] Inherited BSplineCurve3dBase Construct an offset of the instance curve as viewed in the xy-plane (ignoring z).
copyKnots(includeExtraEndKnot: boolean): number[] Inherited BSplineCurve3dBase return a simple array form of the knots.
curveLength(): number Inherited BSplineCurve3dBase Return the length of the curve.
curveLengthBetweenFractions(fraction0: number, fraction1: number): number Inherited BSplineCurve3dBase Returns a (high accuracy) length of the curve between fractional positions.
curveLengthWithFixedIntervalCountQuadrature(fraction0: number, fraction1: number, numInterval: number, numGauss: number5): number Inherited BSplineCurve3dBase Run an integration (with a default Gaussian quadrature) with a fixed fractional step
endPoint(): Point3d Inherited BSplineCurve3dBase Return the end point of the curve
fractionAndDistanceToPointOnTangent(fraction: number, distance: number): Point3d Inherited BSplineCurve3dBase Construct a point extrapolated along tangent at fraction.
fractionToCurvature(fraction: number): undefined | number Inherited BSplineCurve3dBase Returns the (absolute) curvature magnitude.
fractionToFrenetFrame(fraction: number, result?: Transform): undefined | Transform Inherited BSplineCurve3dBase Construct a frenet frame:
fractionToPoint(fraction: number, result?: Point3d): Point3d Inherited BSplineCurve3dBase Evaluate the curve point at fraction
fractionToPointAnd2Derivatives(fraction: number, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors Inherited BSplineCurve3dBase Construct a plane with
fractionToPointAndDerivative(fraction: number, result?: Ray3d): Ray3d Inherited BSplineCurve3dBase Construct a ray with
fractionToPointAndUnitTangent(fraction: number, result?: Ray3d): Ray3d Inherited BSplineCurve3dBase Returns a ray whose origin is the curve point and direction is the unit tangent.
fractionToSignedXYRadiusOfCurvature(fraction: number): number Inherited BSplineCurve3dBase Construct signed distance from a point on the planar curve to its center of curvature (in xy only).
getFractionToDistanceScale(): undefined | number Inherited BSplineCurve3dBase If the curve primitive has distance-along-curve strictly proportional to curve fraction, return the scale factor.
getWrappable(): BSplineWrapMode Inherited BSplineCurve3dBase Get the flag indicating the curve might be suitable for having wrapped "closed" interpretation.
moveSignedDistanceFromFraction(startFraction: number, signedDistance: number, allowExtension: boolean, result?: CurveLocationDetail): CurveLocationDetail Inherited BSplineCurve3dBase (Attempt to) find a position on the curve at a signed distance from start fraction.
moveSignedDistanceFromFractionGeneric(startFraction: number, signedDistance: number, allowExtension: boolean, result?: CurveLocationDetail): CurveLocationDetail Protected Inherited BSplineCurve3dBase Generic algorithm to search for point at signed distance from a fractional startPoint.
poleIndexToDataIndex(poleIndex: number): undefined | number Inherited BSplineCurve3dBase Given a pole index, return the starting index for the contiguous array.
projectedParameterRange(ray: Vector3d | Ray3d, lowHigh?: Range1d): undefined | Range1d Inherited BSplineCurve3dBase Project instance geometry (via dispatch) onto the given ray, and return the extreme fractional parameters of projection.
range(transform?: Transform, result?: Range3d): Range3d Inherited BSplineCurve3dBase Return the range of the entire GeometryQuery tree.
rangeBetweenFractions(fraction0: number, fraction1: number, transform?: Transform): Range3d Inherited BSplineCurve3dBase Returns a (high accuracy) range of the curve between fractional positions
rangeBetweenFractionsByClone(fraction0: number, fraction1: number, transform?: Transform): Range3d Inherited BSplineCurve3dBase Returns a (high accuracy) range of the curve between fractional positions
rangeBetweenFractionsByCount(fraction0: number, fraction1: number, count: number, transform?: Transform, extrapolationFactor: number0.0): Range3d Inherited BSplineCurve3dBase Returns an approximate range based on a fixed number of evaluations
reverseInPlace(): void Inherited BSplineCurve3dBase Reverse the curve in place.
setWrappable(value: BSplineWrapMode): void Inherited BSplineCurve3dBase Set the flag indicating the curve might be suitable for having wrapped "closed" interpretation.
startPoint(): Point3d Inherited BSplineCurve3dBase Return the start point of the curve.
tryTranslateInPlace(dx: number, dy: number0.0, dz: number0.0): boolean Inherited BSplineCurve3dBase Try to move the geometry by dx,dy,dz.
areAlmostEqual(a: GeometryQuery, b: GeometryQuery): boolean Static Inherited BSplineCurve3dBase Apply instance method isAlmostEqual if both are defined.
installStrokeCountMap(curve: CurvePrimitive, curveMap: StrokeCountMap, parentMap?: StrokeCountMap): void Static Inherited BSplineCurve3dBase Final install step to save curveMap in curve.

Properties

Name Type Description
isClosable Accessor ReadOnly boolean Test knots and control points to determine if it is possible to close (aka "wrap") the curve.  

Inherited properties

Name Type Inherited from Description
_bcurve Protected Inherited BSpline1dNd BSplineCurve3dBase The underlying blocked-pole spline, with simple x,y,z poles
children Accessor Inherited ReadOnly undefined | GeometryQuery[] BSplineCurve3dBase Return GeometryQuery children for recursive queries.
* leaf classes do not need to implement.
curvePrimitiveType Readonly Inherited "bsplineCurve" BSplineCurve3dBase String name for schema properties
definitionData Accessor Inherited any BSplineCurve3dBase  
degree Accessor Inherited ReadOnly number BSplineCurve3dBase Return the degree (one less than the order) of the curve
geometryCategory Readonly Inherited "curvePrimitive" BSplineCurve3dBase String name for schema properties
isClosableCurve Accessor Inherited ReadOnly BSplineWrapMode BSplineCurve3dBase Test knots and control points to determine if it is possible to close (aka "wrap") the curve.
isExtensibleFractionSpace Accessor Inherited ReadOnly boolean BSplineCurve3dBase * Returns true if the curve can be easily extended past its start/end point (i.e., beyond the usual
fraction space [0,1]). Otherwise, returns false.
* Base class default implementation returns false.
* These classes (and perhaps others in the future) will return true:
* LineSegment3d
* LineString3d
* Arc3d
knotsRef Accessor Inherited ReadOnly Float64Array BSplineCurve3dBase Return live reference to the knots of the curve.
numPoles Accessor Inherited ReadOnly number BSplineCurve3dBase Return the number of poles
numSpan Accessor Inherited ReadOnly number BSplineCurve3dBase Return the number of bezier spans in the curve. Note that this number includes the number of null spans at repeated knows
order Accessor Inherited ReadOnly number BSplineCurve3dBase Return the order (one more than degree) of the curve
parent Inherited any | undefined BSplineCurve3dBase Data attached by various algorithms (e.g.
poleDimension Accessor Inherited ReadOnly number BSplineCurve3dBase Number of components per pole.
* 3 for conventional (x,y,z) curve
* 4 for weighted (wx,wy,wz,w) curve
polesRef Accessor Inherited ReadOnly Float64Array BSplineCurve3dBase Return live reference to the packed control point coordinates of the curve.
strokeData Inherited StrokeCountMap | undefined BSplineCurve3dBase Data attached during stroking for facets.

Defined in

Last Updated: 21 November, 2024