closestPoint Method

Search for the curve point that is closest to the spacePoint.

  • If the space point is exactly on the curve, this is the reverse of fractionToPoint.
  • Since CurvePrimitive should always have start and end available as candidate points, this method should always succeed

closestPoint(spacePoint: Point3d, _extend: VariantCurveExtendParameter, result?: CurveLocationDetail): undefined | CurveLocationDetail

@returns details of the closest point.

Parameter Type Description
spacePoint Point3d point in space
_extend VariantCurveExtendParameter ignored (pass false). A BSplineCurve3dBase cannot be extended.
result CurveLocationDetail optional pre-allocated detail to populate and return.

Returns - undefined | CurveLocationDetail

details of the closest point.

Defined in

Last Updated: 21 November, 2024