TangentOptions Interface

Options for computing tangents to a curve from a fixed point P. See emitTangents, allTangents, and closestTangent.

Properties

Name Type Description
distanceTol number | undefined Distance tolerance, interpreted as follows:  
extend VariantCurveExtendParameter | undefined Compute tangents to the curve extended according to variant type.  
hintPoint Point3d | undefined The tangent returned by closestTangent is nearest this point as seen in the view plane.  
strokeOptions StrokeOptions | undefined Stroke options for default stroke-based implementations.  
vectorToEye Vector3d | undefined Tangents are computed as seen in a view plane perpendicular to this vector.  

Defined in

Last Updated: 26 April, 2025