allTangents Method
Return all points P
on the curve such that the line containing spacePoint
and P
is tangent to the curve in
the view defined by options.vectorToEye
.
- See emitTangents for the definition of tangency employed.
allTangents(spacePoint: Point3d, options?: TangentOptions): undefined | CurveLocationDetail[]
@returns an array of details of all tangent points or undefined if no tangent was found.
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point in space. |
options | TangentOptions | (optional) options for computing tangents. See TangentOptions for defaults. |
Returns - undefined | CurveLocationDetail[]
an array of details of all tangent points or undefined if no tangent was found.
Defined in
- curve/CurvePrimitive.ts Line 602
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.