emitTangents Method

Announce all points P on the curve such that the line containing spacePoint and P is tangent to the curve in the view defined by options.vectorToEye.

  • Strictly speaking, each tangent line lies in the plane through P whose normal is the cross product of the curve tangent at P and options.vectorToEye. This is equivalent to tangency as seen in a view plane perpendicular to options.vectorToEye.

emitTangents(spacePoint: Point3d, announceTangent: (tangent: CurveLocationDetail) => any, options?: TangentOptions): void

Parameter Type Description
spacePoint Point3d point in space.
announceTangent (tangent: CurveLocationDetail) => any callback to announce each computed tangent. The received CurveLocationDetail is reused
internally, so it should be cloned in the callback if it needs to be saved.
options TangentOptions (optional) options for computing tangents. See TangentOptions for defaults.

Returns - void

Defined in

Last Updated: 26 April, 2025