closestTangent Method
Return the point P
on the curve such that the line containing spacePoint
and P
is tangent to the curve in
the view defined by options.vectorToEye
, and P
is closest to options.hintPoint
in this view.
- See emitTangents for the definition of tangency employed.
closestTangent(spacePoint: Point3d, options?: TangentOptions): undefined | CurveLocationDetail
@returns the detail of the closest tangent point or undefined if no tangent was found.
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point in space. |
options | TangentOptions | (optional) options for computing tangents. See TangentOptions for defaults. |
Returns - undefined | CurveLocationDetail
the detail of the closest tangent point or undefined if no tangent was found.
Defined in
- curve/CurvePrimitive.ts Line 615
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.