BSplineWrapMode Enumeration

B-spline curve and surface types in this library are non-periodic. But they can be created from legacy periodic data. This enumeration lists the possible ways a B-spline object can have been created from legacy periodic data.

Members

Name Value Description
None No conversion performed.
OpenByAddingControlPoints The legacy periodic B-spline data was opened up by adding degree wrap-around poles.
* This is typical of B-spline curves and surfaces constructed with maximum degree - 1 continuity.
* Knots are unaffected by this conversion.
OpenByRemovingKnots The legacy periodic B-spline data was opened up by removing degree exterior knots.
* This is typical of rational B-spline curves representing full circles and ellipses.
* Poles are unaffected by this conversion.

Defined in

Last Updated: 21 February, 2025