appendPlaneIntersectionPoints Method
Implement CurvePrimitive.appendPlaneIntersections
to compute intersections of the curve with a plane.
appendPlaneIntersectionPoints(plane: PlaneAltitudeEvaluator, result: CurveLocationDetail[]): number
@returns number of intersections appended to the array.
Parameter | Type | Description |
---|---|---|
plane | PlaneAltitudeEvaluator | the plane with which to intersect the curve. Concrete types include Plane3dByOriginAndUnitNormal, Point4d, etc. |
result | CurveLocationDetail[] | growing array of plane intersections. |
Returns - number
number of intersections appended to the array.
Defined in
- bspline/BSplineCurve.ts Line 346
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.