constructOffsetXY Method
Construct an offset of the instance curve as viewed in the xy-plane (ignoring z).
constructOffsetXY(offsetDistanceOrOptions: number | OffsetOptions): undefined | BSplineCurve3d
Parameter | Type | Description |
---|---|---|
offsetDistanceOrOptions | number | OffsetOptions | offset distance (positive to left of the instance curve), or options object. |
Returns - undefined | BSplineCurve3d
Defined in
- bspline/BSplineCurve.ts Line 400
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.