GeometryStreamEntryProps Interface
Allowed GeometryStream entries - should only set one value.
@see GeometryStream
Extends
Properties
Name | Type | Description | |
---|---|---|---|
appearance | GeometryAppearanceProps | undefined | ||
brep | BRepEntity.DataProps | undefined | ||
fill | AreaFillProps | undefined | ||
geomPart | GeometryPartInstanceProps | undefined | ||
header | GeometryStreamHeaderProps | undefined | ||
image | ImageGraphicProps | undefined | ||
material | MaterialProps | undefined | ||
pattern | AreaPattern.ParamsProps | undefined | ||
styleMod | LineStyle.ModifierProps | undefined | ||
subRange | Readonly<WritableLowAndHighXYZ> | undefined | ||
textString | TextStringProps | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
arc | IModelJson.ArcByVectorProps | [XYZProps, XYZProps, XYZProps] | GeomJson.GeometryProps | {arc:...} |
bagofCurves | [IModelJson.CurveCollectionProps] | undefined | GeomJson.GeometryProps | A collection of curves with no required structure or connections: |
bcurve | IModelJson.BcurveProps | undefined | GeomJson.GeometryProps | {bcurve:...} |
box | IModelJson.BoxProps | undefined | GeomJson.GeometryProps | {box:...} |
bsurf | IModelJson.BSplineSurfaceProps | undefined | GeomJson.GeometryProps | {bsurf:...} |
cone | IModelJson.ConeProps | undefined | GeomJson.GeometryProps | {cone:............} |
cylinder | IModelJson.CylinderProps | undefined | GeomJson.GeometryProps | {cylinder:...} |
indexedMesh | IModelJson.IndexedMeshProps | undefined | GeomJson.GeometryProps | {indexedMesh:...} |
interpolationCurve | InterpolationCurve3dProps | undefined | GeomJson.GeometryProps | `{interpolationCurve:...}~ |
lineSegment | [XYZProps, XYZProps] | undefined | GeomJson.GeometryProps | {lineSegment:...} |
lineString | XYZProps[] | undefined | GeomJson.GeometryProps | {lineString:...} |
linearSweep | IModelJson.LinearSweepProps | undefined | GeomJson.GeometryProps | {linearSweep:.........} |
loop | [IModelJson.CurvePrimitiveProps] | undefined | GeomJson.GeometryProps | {loop:...} |
parityRegion | [{ loop: [IModelJson.CurvePrimitiveProps] }] | undefined | GeomJson.GeometryProps | {parityRegion:...} |
path | [IModelJson.CurvePrimitiveProps] | undefined | GeomJson.GeometryProps | A sequence of curves joined head to tail: |
point | XYZProps | undefined | GeomJson.GeometryProps | {point:...} |
pointString | XYZProps[] | undefined | GeomJson.GeometryProps | {pointString:...} |
rotationalSweep | IModelJson.RotationalSweepProps | undefined | GeomJson.GeometryProps | {rotationalSweep:...} |
ruledSweep | IModelJson.RuledSweepProps | undefined | GeomJson.GeometryProps | {ruledSweep:...} |
sphere | IModelJson.SphereProps | undefined | GeomJson.GeometryProps | {sphere:............} |
torusPipe | IModelJson.TorusPipeProps | undefined | GeomJson.GeometryProps | {torusPipe:............} |
transitionSpiral | IModelJson.TransitionSpiralProps | undefined | GeomJson.GeometryProps | {transitionSpiral:...} |
unionRegion | [IModelJson.PlanarRegionProps] | undefined | GeomJson.GeometryProps | {unionRegion:...} |
Defined in
Last Updated: 12 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.