IModelJson.TransitionSpiralProps Interface
Interface for spiral
- Any 4 (but not 5) of the 5 values
[startBearing, endBearing, startRadius, endRadius, length]
may be defined. - In radius data, zero radius indicates straight line (infinite radius)
- Note that the inherited AxesProps allows multiple ways to specify orientation of the placement..
Extends
Properties
Name | Type | Description | |
---|---|---|---|
activeFractionInterval | number[] | undefined | Fractional part of active interval. | |
endBearing | AngleProps | undefined | End bearing. | |
endRadius | number | undefined | Radius at end (0 for straight line) | |
length | number | undefined | length along curve. | |
origin | XYZProps | origin of the coordinate system. | |
startBearing | AngleProps | undefined | angle at departure from origin. | |
startRadius | number | undefined | Radius at start (0 for straight line) | |
type | string | undefined | TransitionSpiral type. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
xyVectors Inherited | [XYZProps, XYZProps] | undefined | IModelJson.AxesProps | A rotation specified by an array of two vectors [xAxis, yAxis]. |
xyzVectors Inherited | [XYZProps, XYZProps, XYZProps] | undefined | IModelJson.AxesProps | A local coordinate system specified by an array of three vectors [xAxis, yAxis, zAxis]. |
yawPitchRollAngles Inherited | YawPitchRollProps | undefined | IModelJson.AxesProps | A rotation specified by yaw, pitch, roll angles. |
zxVectors Inherited | [XYZProps, XYZProps] | undefined | IModelJson.AxesProps | A rotation specified by an array of two vectors [zAxis, xAxis]. |
Defined in
- serialization/IModelJsonSchema.ts Line 343
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.