IModelJson.AxesProps Interface

Ways to specify an object's local coordinate frame.

  • Most objects that implement AxesProps specify their local coordinate frame by a right-handed rotation matrix (yawPitchRollAngles, xyVectors, zxVectors).
  • A general invertible matrix can be specified by xyzVectors.
  • An object that implements AxesProps typically specifies only one variant, or none for Identity.

Properties

Name Type Description
xyVectors [XYZProps, XYZProps] | undefined A rotation specified by an array of two vectors [xAxis, yAxis].  
xyzVectors [XYZProps, XYZProps, XYZProps] | undefined A local coordinate system specified by an array of three vectors [xAxis, yAxis, zAxis].  
yawPitchRollAngles YawPitchRollProps | undefined A rotation specified by yaw, pitch, roll angles.  
zxVectors [XYZProps, XYZProps] | undefined A rotation specified by an array of two vectors [zAxis, xAxis].  

Defined in

Last Updated: 05 April, 2025