IModelJson.SphereProps Interface
Interface for a Sphere.
- Local coordinate frame is supplied by an AxesProps:
- Typically this is a
zxVectors
. - Skew axes can be specified with
xyzVectors
, in which case any specified radii scale these axes; all other AxesProps specify a right-handed orthonormal triad.
- Typically this is a
Extends
Properties
Name | Type | Description | |
---|---|---|---|
capped | boolean | undefined | optional capping flag. | |
center | XYZProps | Center of the sphere coordinate system | |
latitudeStartEnd | AngleSweepProps | undefined | optional sweep range for latitude. | |
radius | number | undefined | primary radius | |
radiusX | number | undefined | optional x radius | |
radiusY | number | undefined | optional y radius | |
radiusZ | number | undefined | optional z radius |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
xyVectors Inherited | [XYZProps, XYZProps] | undefined | IModelJson.AxesProps | A rotation specified by an array of two vectors [xAxis, yAxis]. |
xyzVectors Inherited | [XYZProps, XYZProps, XYZProps] | undefined | IModelJson.AxesProps | A local coordinate system specified by an array of three vectors [xAxis, yAxis, zAxis]. |
yawPitchRollAngles Inherited | YawPitchRollProps | undefined | IModelJson.AxesProps | A rotation specified by yaw, pitch, roll angles. |
zxVectors Inherited | [XYZProps, XYZProps] | undefined | IModelJson.AxesProps | A rotation specified by an array of two vectors [zAxis, xAxis]. |
Defined in
- serialization/IModelJsonSchema.ts Line 450
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.