IModelJson.ConeProps Interface
Interface for a Cone, defined by two centers and radii.
- A Cone typically has circular sections perpendicular to the axis line between centers.
- The cross section xy-plane is specified by an AxesProps:
- Typically this is an
xyVectors
. - Elliptical cross sections can be specified with
xyzVectors
, which admits skew vectors and/or vectors of different lengths. Elliptical cross sections are scaled by radius.
- Typically this is an
Extends
Properties
Name | Type | Description | |
---|---|---|---|
capped | boolean | undefined | flag for circular end caps. | |
end | XYZProps | Point on axis at center of end section. | |
endRadius | number | undefined | Radius of the section at end if circular, or scale factor if elliptical. |
|
radius | number | undefined | Constant radius of all sections if circular, or scale factor if elliptical. | |
start | XYZProps | Point on axis at center of start section. | |
startRadius | number | undefined | Radius of the section at start if circular, or scale factor if elliptical. |
|
vectorX | XYZProps | undefined | Optional section x-axis. | Deprecated |
vectorY | XYZProps | undefined | Optional section y-axis. | Deprecated |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
xyVectors Inherited | [XYZProps, XYZProps] | undefined | IModelJson.AxesProps | A rotation specified by an array of two vectors [xAxis, yAxis]. |
xyzVectors Inherited | [XYZProps, XYZProps, XYZProps] | undefined | IModelJson.AxesProps | A local coordinate system specified by an array of three vectors [xAxis, yAxis, zAxis]. |
yawPitchRollAngles Inherited | YawPitchRollProps | undefined | IModelJson.AxesProps | A rotation specified by yaw, pitch, roll angles. |
zxVectors Inherited | [XYZProps, XYZProps] | undefined | IModelJson.AxesProps | A rotation specified by an array of two vectors [zAxis, xAxis]. |
Defined in
- serialization/IModelJsonSchema.ts Line 251
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.