IModelJson.GeometryProps Interface
Property rules for json objects that can be deserialized to various Curve and Solid objects
Extends
Properties
Name | Type | Description | |
---|---|---|---|
bsurf | IModelJson.BSplineSurfaceProps | undefined | {bsurf:...} |
|
indexedMesh | IModelJson.IndexedMeshProps | undefined | {indexedMesh:...} |
|
point | XYZProps | undefined | {point:...} |
|
pointString | XYZProps[] | undefined | {pointString:...} |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
arc Inherited | IModelJson.ArcByVectorProps | [XYZProps, XYZProps, XYZProps] | IModelJson.CurvePrimitiveProps | {arc:...} |
bagofCurves Inherited | [IModelJson.CurveCollectionProps] | undefined | CurveCollectionProps | A collection of curves with no required structure or connections: |
bcurve Inherited | IModelJson.BcurveProps | undefined | IModelJson.CurvePrimitiveProps | {bcurve:...} |
box Inherited | IModelJson.BoxProps | undefined | SolidPrimitiveProps | {box:...} |
cone Inherited | IModelJson.ConeProps | undefined | SolidPrimitiveProps | {cone:............} |
cylinder Inherited | IModelJson.CylinderProps | undefined | SolidPrimitiveProps | {cylinder:...} |
interpolationCurve Inherited | InterpolationCurve3dProps | undefined | IModelJson.CurvePrimitiveProps | `{interpolationCurve:...}~ |
linearSweep Inherited | IModelJson.LinearSweepProps | undefined | SolidPrimitiveProps | {linearSweep:.........} |
lineSegment Inherited | [XYZProps, XYZProps] | undefined | IModelJson.CurvePrimitiveProps | {lineSegment:...} |
lineString Inherited | XYZProps[] | undefined | IModelJson.CurvePrimitiveProps | {lineString:...} |
loop Inherited | [IModelJson.CurvePrimitiveProps] | undefined | CurveCollectionProps | {loop:...} |
parityRegion Inherited | [{ loop: [IModelJson.CurvePrimitiveProps] }] | undefined | CurveCollectionProps | {parityRegion:...} |
path Inherited | [IModelJson.CurvePrimitiveProps] | undefined | CurveCollectionProps | A sequence of curves joined head to tail: |
rotationalSweep Inherited | IModelJson.RotationalSweepProps | undefined | SolidPrimitiveProps | {rotationalSweep:...} |
ruledSweep Inherited | IModelJson.RuledSweepProps | undefined | SolidPrimitiveProps | {ruledSweep:...} |
sphere Inherited | IModelJson.SphereProps | undefined | SolidPrimitiveProps | {sphere:............} |
torusPipe Inherited | IModelJson.TorusPipeProps | undefined | SolidPrimitiveProps | {torusPipe:............} |
transitionSpiral Inherited | IModelJson.TransitionSpiralProps | undefined | IModelJson.CurvePrimitiveProps | {transitionSpiral:...} |
unionRegion Inherited | [IModelJson.PlanarRegionProps] | undefined | CurveCollectionProps | {unionRegion:...} |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.