IModelJson.CurveCollectionProps Interface

Interface for a collection of curves, e.g. as used as a swept contour.

Extends

Properties

Name Type Description
bagofCurves [IModelJson.CurveCollectionProps] | undefined A collection of curves with no required structure or connections Deprecated  
bagOfCurves [IModelJson.CurvePrimitiveProps | IModelJson.CurveCollectionProps] | undefined A collection of curves with no required structure or connections.  
path [IModelJson.CurvePrimitiveProps] | undefined A sequence of curves joined head to tail.  

Inherited properties

Name Type Inherited from Description
loop Inherited [IModelJson.CurvePrimitiveProps] | undefined IModelJson.PlanarRegionProps {loop:...}
parityRegion Inherited [{ loop: [IModelJson.CurvePrimitiveProps] }] | undefined IModelJson.PlanarRegionProps {parityRegion:...}
unionRegion Inherited [IModelJson.PlanarRegionProps] | undefined IModelJson.PlanarRegionProps {unionRegion:...}

Defined in

Last Updated: 21 February, 2025