MapLayerTileTreeReference Class
A TileTreeReference to be used specifically for MapTileTrees. The reference refers to its MapTileTree by way of the tree's TileTreeOwner. Multiple MapLayerTileTreeReferences can refer to the same TileTree if the map layer settings are equivalent, meaning they have identical format IDs, URLs, credentials, etc.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
canSupplyToolTip(hit: HitDetail): boolean | Return whether this TileTreeReference can supply a tooltip describing the entity represented by the specified hit. | |
getToolTip(hit: HitDetail): Promise<undefined | string | HTMLElement> | Return a tooltip describing the hit, or undefined if no tooltip can be supplied. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
_collectTileGeometry(collector: TileGeometryCollector): void Protected Inherited | TileTreeReference | A function that can be assigned to collectTileGeometry to enable geometry collection for references to tile trees that support geometry collection. |
_createGeometryTreeReference(): undefined | GeometryTileTreeReference Protected Inherited | TileTreeReference | Create a tile tree reference equivalent to this one that also supplies an implementation of collectTileGeometry. |
accumulateTransformedRange(range: Range3d, matrix: Matrix4d, frustumPlanes?: FrustumPlanes): void Inherited | TileTreeReference | |
addLogoCards(_cards: HTMLTableElement, _vp: ScreenViewport): void Inherited | TileTreeReference | Add attribution logo cards for the tile tree source logo cards to the viewport's logo div. |
addToScene(context: SceneContext): void Inherited | TileTreeReference | Adds this reference's graphics to the scene. |
collectStatistics(stats: RenderMemory.Statistics): void Inherited | TileTreeReference | Record graphics memory consumed by this tile tree reference. |
computeTransform(tree: TileTree): Transform Protected Inherited | TileTreeReference | Compute a transform from this tile tree reference's coordinate space to the IModelConnection's coordinate space. |
computeWorldContentRange(): Range3d Inherited | TileTreeReference | Compute the range of this tile tree's contents in world coordinates. |
createDrawArgs(context: SceneContext): undefined | TileDrawArgs Inherited | TileTreeReference | Create context for drawing the tile tree, if it is ready for drawing. |
createGeometryTreeReference(): undefined | GeometryTileTreeReference Inherited | TileTreeReference | Obtain a tile tree reference equivalent to this one that also supplies an implementation of collectTileGeometry, or |
decorate(_context: DecorateContext): void Inherited | TileTreeReference | Optionally add any decorations specific to this reference. |
discloseTileTrees(trees: DisclosedTileTreeSet): void Inherited | TileTreeReference | Disclose all TileTrees use by this reference. |
draw(args: TileDrawArgs): void Inherited | TileTreeReference | Adds this reference's graphics to the scene. |
getAppearanceProvider(_tree: TileTree): undefined | FeatureAppearanceProvider Protected Inherited | TileTreeReference | Return a provider that can supplement the view's symbology overrides. |
getClipVolume(tree: TileTree): undefined | RenderClipVolume Protected Inherited | TileTreeReference | Return the clip volume applied to this reference's tile tree, if any. |
getHiddenLineSettings(_tree: TileTree): undefined | HiddenLine.Settings Protected Inherited | TileTreeReference | Return hidden line settings to replace those defined for the view. |
getLocation(): undefined | Transform Inherited | TileTreeReference | Supply transform from this tile tree reference's location to iModel coordinate space. |
getSymbologyOverrides(_tree: TileTree): undefined | FeatureSymbology.Overrides Protected Inherited | TileTreeReference | Return overrides that replace any defined for the view. |
getToolTipPromise(hit: HitDetail): undefined | Promise<undefined | string | HTMLElement> Inherited | TileTreeReference | Obtain a tooltip describing the specified hit , or undefined if this tile tree reference cannot supply a tooltip for the hit. |
getTransformFromIModel(): undefined | Transform Inherited | TileTreeReference | |
getViewFlagOverrides(tree: TileTree): Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> Protected Inherited | TileTreeReference | Supply overrides that should be applied to the ViewState's ViewFlags when drawing this tile tree reference. |
unionFitRange(union: Range3d): void Inherited | TileTreeReference | Unions this reference's range with the supplied range to help compute a volume in world space for fitting a viewport to its contents. |
createFromRenderGraphic(args: RenderGraphicTileTreeArgs): TileTreeReference Static Inherited | TileTreeReference | Create a TileTreeReference that displays a pre-defined RenderGraphic. |
Properties
Name | Type | Description | |
---|---|---|---|
_layerIndex Protected | number | ||
_layerSettings Protected | MapLayerSettings | ||
_transparency Accessor Protected ReadOnly | undefined | number | ||
imageryProvider Accessor ReadOnly | undefined | MapLayerImageryProvider | Returns the imagery provider for the tile tree. | |
iModel | IModelConnection | ||
isOpaque Accessor ReadOnly | boolean | Returns true if the associated map layer, including its sublayers, is opaque. | |
layerIndex Accessor ReadOnly | number | Returns the index of the map layer associated with the tile tree. | |
layerName Accessor ReadOnly | string | ||
layerSettings Accessor | MapLayerSettings | Returns the layer settings for the map layer. | |
transparency Accessor ReadOnly | undefined | number | Returns the transparency value of the map layer. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_isLoadingComplete Accessor Protected Inherited ReadOnly | boolean | TileTreeReference | Override if additional asynchronous loading is required after the tile tree is successfully loaded, to indicate when that loading has completed. |
castsShadows Accessor Inherited ReadOnly | boolean | TileTreeReference | Return whether the geometry exposed by this tile tree reference should cast shadows on other geometry. |
collectTileGeometry Inherited | (collector: TileGeometryCollector) => void | undefined | TileTreeReference | If defined, supplies the implementation of collectTileGeometry. |
isGlobal Accessor Inherited ReadOnly | boolean | TileTreeReference | Return whether this reference has global coverage. Mapping data is global and some non-primary models such as the OSM building layer have global coverage |
isLoadingComplete Accessor Inherited ReadOnly | boolean | TileTreeReference | Return true if the tile tree is fully loaded and ready to draw. The default implementation returns true if the tile tree loading process completed (whether it resulted in success or failure). |
planarClipMaskPriority Accessor Inherited ReadOnly | number | TileTreeReference | The PlanarClipMaskPriority of this tile tree used to determine which tile trees contribute to a clip mask when using PlanarClipMaskMode.Priority. |
treeOwner Accessor Abstract Inherited ReadOnly | TileTreeOwner | TileTreeReference | The owner of the currently-referenced TileTree. Do not store a direct reference to it, because it may change or become disposed at any time. |
Defined in
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.