MapLayerImageryProvider Class
Abstract class for map layer imagery providers. Map layer imagery providers request and provide tile images and other data. Each map layer from a separate source needs its own imagery provider object.
Methods
Name | Description | |
---|---|---|
constructor(_settings: ImageMapLayerSettings, _usesCachedTiles: boolean): MapLayerImageryProvider | ||
_generateChildIds(quadId: QuadId, resolveChildren: (childIds: QuadId[]) => void): void Protected | Get child IDs of a quad and generate tiles based on these child IDs. | |
addLogoCards(_cards: HTMLTableElement, _viewport: ScreenViewport): void | Add attribution logo cards for the data supplied by this provider to the Viewport's logo div. | |
constructUrl(row: number, column: number, zoomLevel: number): Promise<string> Abstract | ||
initialize(): Promise<void> | Initialize the provider by loading the first tile at its default maximum zoom level. | |
loadTile(row: number, column: number, zoomLevel: number): Promise<undefined | ImageSource> | Returns a map layer tile at the specified settings. | |
resetStatus(): void |
Properties
Name | Type | Description | |
---|---|---|---|
_hasSuccessfullyFetchedTile Protected | boolean | ||
_settings Protected Readonly | ImageMapLayerSettings | ||
_usesCachedTiles Protected | boolean | ||
cartoRange | MapCartoRectangle | undefined | ||
maximumZoomLevel Accessor ReadOnly | number | ||
minimumZoomLevel Accessor ReadOnly | number | ||
mutualExclusiveSubLayer Accessor ReadOnly | boolean | ||
onStatusChanged Readonly | BeEvent<(provider: MapLayerImageryProvider) => void> | ||
supportsMapFeatureInfo Accessor ReadOnly | boolean | Determine if this provider supports map feature info. | |
tilingScheme Accessor ReadOnly | MapTilingScheme |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.