IRuleSuppressionSet Interface

Interface used to represent logical collection of ISuppressionRule instances.

Properties

Name Type Description
classRuleSuppressions IRuleSuppressionMap<AnyClass, object>[] | undefined    
constantRuleSuppressions IRuleSuppressionMap<Constant, object>[] | undefined    
customAttributeContainerSuppressions IRuleSuppressionMap<CustomAttributeContainerProps, object>[] | undefined    
customAttributeInstanceSuppressions BaseRuleSuppressionMap<CustomAttributeContainerProps, CustomAttribute>[] | undefined    
customAttributeRuleSuppressions IRuleSuppressionMap<CustomAttributeClass, object>[] | undefined    
entityRuleSuppressions IRuleSuppressionMap<EntityClass, object>[] | undefined    
enumerationRuleSuppressions IRuleSuppressionMap<Enumeration, object>[] | undefined    
formatRuleSuppressions IRuleSuppressionMap<Format, object>[] | undefined    
invertedUnitRuleSuppressions IRuleSuppressionMap<InvertedUnit, object>[] | undefined    
koqRuleSuppressions IRuleSuppressionMap<KindOfQuantity, object>[] | undefined    
mixinRuleSuppressions IRuleSuppressionMap<Mixin, object>[] | undefined    
name string    
phenomenonRuleSuppressions IRuleSuppressionMap<Phenomenon, object>[] | undefined    
propertyCategoryRuleSuppressions IRuleSuppressionMap<PropertyCategory, object>[] | undefined    
propertyRuleSuppressions IRuleSuppressionMap<AnyProperty, object>[] | undefined    
relationshipConstraintRuleSuppressions IRuleSuppressionMap<RelationshipConstraint, object>[] | undefined    
relationshipRuleSuppressions IRuleSuppressionMap<RelationshipClass, object>[] | undefined    
schemaItemRuleSuppressions IRuleSuppressionMap<SchemaItem, object>[] | undefined    
schemaRuleSuppressions IRuleSuppressionMap<Schema, object>[] | undefined    
structRuleSuppressions IRuleSuppressionMap<StructClass, object>[] | undefined    
unitRuleSuppressions IRuleSuppressionMap<Unit, object>[] | undefined    
unitSystemRuleSuppressions IRuleSuppressionMap<UnitSystem, object>[] | undefined    

Defined in

Last Updated: 21 November, 2024