GeometricModel2dState Class

Represents the front-end state of a GeometricModel2d.

Extends

Extended by

Implements

Methods

Name Description
constructor(props: GeometricModel2dProps, iModel: IModelConnection, state?: GeometricModel2dState): GeometricModel2dState    
toJSON(): GeometricModel2dProps Add all custom-handled properties of a Model to a json object.  

Inherited methods

Name Inherited from Description
clone(iModel?: IModelConnection): this Inherited GeometricModelState Make an independent copy of this EntityState
equals(other: this): boolean Inherited GeometricModelState Return true if this EntityState is equal to another one.
queryModelRange(): Promise<Range3d> Inherited GeometricModelState Query for the union of the ranges of all the elements in this GeometricModel.

Properties

Name Type Description
asGeometricModel2d Accessor ReadOnly GeometricModel2dState Attempts to cast this model to a 2d geometric model.  
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  
is3d Accessor ReadOnly boolean Returns true if this is a 3d model (a GeometricModel3dState).  

Inherited properties

Name Type Inherited from Description
asGeometricModel Accessor Inherited ReadOnly GeometricModelState GeometricModelState Attempts to cast this model to a geometric model.
asGeometricModel3d Accessor Inherited ReadOnly undefined | GeometricModel3dState GeometricModelState Attempts to cast this model to a 3d geometric model.
asSpatialModel Accessor Inherited ReadOnly undefined | SpatialModelState GeometricModelState Attempts to cast this model to a spatial model.
classFullName Accessor Static Inherited ReadOnly string GeometricModelState Get full BIS class name of this Entity in the form "SchemaName:ClassName".
classFullName Readonly Inherited string GeometricModelState The full class name in the form "schema:class".
className Accessor Inherited ReadOnly string GeometricModelState The name of the BIS class associated with this class.
id Readonly Inherited string GeometricModelState The Id of this Entity.
iModel Readonly Inherited IModelConnection GeometricModelState The iModel from which this Entity was loaded
is2d Accessor Inherited ReadOnly boolean GeometricModelState Returns true if this is a 2d model (a GeometricModel2dState).
isGeometricModel Accessor Inherited ReadOnly boolean GeometricModelState Determine whether this is a GeometricModel
isPrivate Readonly Inherited boolean GeometricModelState  
isTemplate Readonly Inherited boolean GeometricModelState  
jsonProperties Readonly Inherited { T } GeometricModelState Optional json properties of this Entity.
modeledElement Readonly Inherited RelatedElement GeometricModelState  
name Readonly Inherited string GeometricModelState  
parentModel Inherited string GeometricModelState  
schemaName Accessor Static Inherited ReadOnly string GeometricModelState The name of the BIS schema for this class.

Defined in

Last Updated: 21 November, 2024