GeometricModel2d Class

A container for persisting 2d geometric elements.

Extends

Extended by

Methods

Name Description
constructor(props: GeometricModel2dProps, iModel: IModelDb): GeometricModel2d Protected    
toJSON(): GeometricModel2dProps Obtain the JSON representation of this Entity.  

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited GeometricModel Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited GeometricModel Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited GeometricModel Call a function for each property of this Entity.
getJsonProperty(name: string): any Inherited GeometricModel  
getReferenceIds(): EntityReferenceSet Inherited GeometricModel Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any Inherited GeometricModel Get a set of JSON user properties by namespace
insert(): string Inherited GeometricModel Insert this Model in the iModel
queryExtents(): Range3d Inherited GeometricModel Query for the union of the extents of the elements contained by this model.
queryRange(): Promise<Range3d> Inherited GeometricModel Query for the union of the extents of all elements contained within this model.
removeUserProperties(nameSpace: string): void Inherited GeometricModel Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void Inherited GeometricModel  
setUserProperties(nameSpace: string, value: any): void Inherited GeometricModel Change a set of user JSON properties of this Element by namespace.
update(): void Inherited GeometricModel Update this Model in the iModel.
is(otherClass: ): boolean Static Inherited GeometricModel return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void Protected Static Inherited GeometricModel Called before a Model is deleted.
onDeleted(_arg: OnModelIdArg): void Protected Static Inherited GeometricModel Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GeometricModel Called after an Element in an instance of a Model of this class has been deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GeometricModel Called when an Element in an instance of a Model of this class is about to be deleted.
onInsert(arg: OnModelPropsArg): void Protected Static Inherited GeometricModel Called before a new Model is inserted.
onInserted(_arg: OnModelIdArg): void Protected Static Inherited GeometricModel Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GeometricModel Called after an Element has been inserted into an instance of a Model of this class.
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited GeometricModel Called before a prospective Element is to be inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void Protected Static Inherited GeometricModel Called before a Model is updated.
onUpdated(_arg: OnModelIdArg): void Protected Static Inherited GeometricModel Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GeometricModel Called after an Element in an instance of a Model of this class has been updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited GeometricModel Called when an Element in an instance of a Model of this class is about to be updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  
globalOrigin Point2d | undefined The actual coordinates of (0,0) in modeling coordinates.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string GeometricModel Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string GeometricModel Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string GeometricModel The name of the BIS class associated with this class.
geometryGuid Inherited string | undefined GeometricModel  
id Inherited string GeometricModel The Id of this Entity.
iModel Inherited IModelDb GeometricModel The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" GeometricModel An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean GeometricModel  
isTemplate Inherited boolean GeometricModel  
jsonProperties Readonly Inherited { T } GeometricModel  
modeledElement Readonly Inherited RelatedElement GeometricModel  
name Readonly Inherited string GeometricModel  
parentModel Readonly Inherited string GeometricModel  
schema Static Inherited GeometricModel The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string GeometricModel The name of the BIS Schema that defines this class

Defined in

Last Updated: 21 November, 2024