GraphicalModel2d Class

A container for persisting 2d graphical elements.

Extends

Extended by

Methods

Name Description
constructor(props: GeometricModel2dProps, iModel: IModelDb): GraphicalModel2d Protected    

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited GeometricModel2d Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited GeometricModel2d Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited GeometricModel2d Call a function for each property of this Entity.
getJsonProperty(name: string): any Inherited GeometricModel2d  
getReferenceIds(): EntityReferenceSet Inherited GeometricModel2d Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any Inherited GeometricModel2d Get a set of JSON user properties by namespace
insert(): string Inherited GeometricModel2d Insert this Model in the iModel
queryExtents(): Range3d Inherited GeometricModel2d Query for the union of the extents of the elements contained by this model.
queryRange(): Promise<Range3d> Inherited GeometricModel2d Query for the union of the extents of all elements contained within this model.
removeUserProperties(nameSpace: string): void Inherited GeometricModel2d Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void Inherited GeometricModel2d  
setUserProperties(nameSpace: string, value: any): void Inherited GeometricModel2d Change a set of user JSON properties of this Element by namespace.
toJSON(): GeometricModel2dProps Inherited GeometricModel2d Obtain the JSON representation of this Entity.
update(): void Inherited GeometricModel2d Update this Model in the iModel.
is(otherClass: ): boolean Static Inherited GeometricModel2d return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void Protected Static Inherited GeometricModel2d Called before a Model is deleted.
onDeleted(_arg: OnModelIdArg): void Protected Static Inherited GeometricModel2d Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GeometricModel2d Called after an Element in an instance of a Model of this class has been deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GeometricModel2d Called when an Element in an instance of a Model of this class is about to be deleted.
onInsert(arg: OnModelPropsArg): void Protected Static Inherited GeometricModel2d Called before a new Model is inserted.
onInserted(_arg: OnModelIdArg): void Protected Static Inherited GeometricModel2d Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GeometricModel2d Called after an Element has been inserted into an instance of a Model of this class.
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited GeometricModel2d Called before a prospective Element is to be inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void Protected Static Inherited GeometricModel2d Called before a Model is updated.
onUpdated(_arg: OnModelIdArg): void Protected Static Inherited GeometricModel2d Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GeometricModel2d Called after an Element in an instance of a Model of this class has been updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited GeometricModel2d Called when an Element in an instance of a Model of this class is about to be updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string GeometricModel2d Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string GeometricModel2d Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string GeometricModel2d The name of the BIS class associated with this class.
geometryGuid Inherited string | undefined GeometricModel2d  
globalOrigin Inherited Point2d | undefined GeometricModel2d The actual coordinates of (0,0) in modeling coordinates.
id Inherited string GeometricModel2d The Id of this Entity.
iModel Inherited IModelDb GeometricModel2d The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" GeometricModel2d An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean GeometricModel2d  
isTemplate Inherited boolean GeometricModel2d  
jsonProperties Readonly Inherited { T } GeometricModel2d  
modeledElement Readonly Inherited RelatedElement GeometricModel2d  
name Readonly Inherited string GeometricModel2d  
parentModel Readonly Inherited string GeometricModel2d  
schema Static Inherited GeometricModel2d The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string GeometricModel2d The name of the BIS Schema that defines this class

Defined in

Last Updated: 21 November, 2024