GeometricModel2dProps Interface

Properties that define a GeometricModel2d

Extends

Properties

Name Type Description
globalOrigin XYProps | undefined The actual coordinates of (0,0) in modeling coordinates.  

Inherited properties

Name Type Inherited from Description
classFullName Inherited string GeometricModelProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
geometryGuid Inherited string | undefined GeometricModelProps A unique identifier that is updated each time a change affecting the appearance of a geometric element within this model
id Inherited string | undefined GeometricModelProps The Id of the entity.
isInstanceOfEntity Readonly Inherited undefined | undefined GeometricModelProps A non-existent property used to discriminate between EntityProps and Entity.
isPrivate Inherited boolean | undefined GeometricModelProps  
isTemplate Inherited boolean | undefined GeometricModelProps  
jsonProperties Inherited any | undefined GeometricModelProps Optional json properties of this Entity.
modeledElement Inherited RelatedElementProps GeometricModelProps  
name Inherited string | undefined GeometricModelProps  
parentModel Inherited string | undefined GeometricModelProps  

Defined in

Last Updated: 21 November, 2024