SpatialModelState Class
Represents the front-end state of a SpatialModel.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(props: ModelProps, iModel: IModelConnection, state?: SpatialModelState): SpatialModelState |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): this Inherited | GeometricModel3dState | Make an independent copy of this EntityState |
equals(other: this): boolean Inherited | GeometricModel3dState | Return true if this EntityState is equal to another one. |
queryModelRange(): Promise<Range3d> Inherited | GeometricModel3dState | Query for the union of the ranges of all the elements in this GeometricModel. |
toJSON(): GeometricModel3dProps Inherited | GeometricModel3dState | Add all custom-handled properties of a Model to a json object. |
Properties
Name | Type | Description | |
---|---|---|---|
asSpatialModel Accessor ReadOnly | SpatialModelState | Attempts to cast this model to a spatial model. | |
classifiers Readonly | SpatialClassifiersState | undefined | If this is a reality model, provides access to a list of available spatial classifiers that can be applied to it. | |
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. | |
isRealityModel Accessor ReadOnly | boolean | Return true if this is a reality model (represented by a 3d tile set). |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
asGeometricModel Accessor Inherited ReadOnly | GeometricModelState | GeometricModel3dState | Attempts to cast this model to a geometric model. |
asGeometricModel2d Accessor Inherited ReadOnly | undefined | GeometricModel2dState | GeometricModel3dState | Attempts to cast this model to a 2d geometric model. |
asGeometricModel3d Accessor Inherited ReadOnly | GeometricModel3dState | GeometricModel3dState | Attempts to cast this model to a 3d geometric model. |
classFullName Accessor Static Inherited ReadOnly | string | GeometricModel3dState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly Inherited | string | GeometricModel3dState | The full class name in the form "schema:class". |
className Accessor Inherited ReadOnly | string | GeometricModel3dState | The name of the BIS class associated with this class. |
id Readonly Inherited | string | GeometricModel3dState | The Id of this Entity. |
iModel Readonly Inherited | IModelConnection | GeometricModel3dState | The iModel from which this Entity was loaded |
is2d Accessor Inherited ReadOnly | boolean | GeometricModel3dState | Returns true if this is a 2d model (a GeometricModel2dState). |
is3d Accessor Inherited ReadOnly | boolean | GeometricModel3dState | Returns true if this is a 3d model (a GeometricModel3dState). |
isGeometricModel Accessor Inherited ReadOnly | boolean | GeometricModel3dState | Determine whether this is a GeometricModel |
isNotSpatiallyLocated Readonly Inherited | boolean | GeometricModel3dState | If true, then the elements in this GeometricModel3dState are not in real-world coordinates and will not be in the spatial index. |
isPlanProjection Readonly Inherited | boolean | GeometricModel3dState | If true, then the elements in this GeometricModel3dState are expected to be in an XY plane. |
isPrivate Readonly Inherited | boolean | GeometricModel3dState | |
isSpatiallyLocated Accessor Inherited ReadOnly | boolean | GeometricModel3dState | If true, then the elements in this GeometricModel3dState are in real-world coordinates and will be in the spatial index. |
isTemplate Readonly Inherited | boolean | GeometricModel3dState | |
jsonProperties Readonly Inherited | { T } | GeometricModel3dState | Optional json properties of this Entity. |
modeledElement Readonly Inherited | RelatedElement | GeometricModel3dState | |
name Readonly Inherited | string | GeometricModel3dState | |
parentModel Inherited | string | GeometricModel3dState | |
schemaName Accessor Static Inherited ReadOnly | string | GeometricModel3dState | The name of the BIS schema for this class. |
Defined in
- core/frontend/src/ModelState.ts Line 270
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.