PhysicalModelState Class
Represents the front-end state of a PhysicalModel.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: ModelProps, iModel: IModelConnection, state?: SpatialModelState): PhysicalModelState |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): this Inherited | SpatialModelState | Make an independent copy of this EntityState |
equals(other: this): boolean Inherited | SpatialModelState | Return true if this EntityState is equal to another one. |
queryModelRange(): Promise<Range3d> Inherited | SpatialModelState | Query for the union of the ranges of all the elements in this GeometricModel. |
toJSON(): GeometricModel3dProps Inherited | SpatialModelState | Add all custom-handled properties of a Model to a json object. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
asGeometricModel Accessor Inherited ReadOnly | GeometricModelState | SpatialModelState | Attempts to cast this model to a geometric model. |
asGeometricModel2d Accessor Inherited ReadOnly | undefined | GeometricModel2dState | SpatialModelState | Attempts to cast this model to a 2d geometric model. |
asGeometricModel3d Accessor Inherited ReadOnly | GeometricModel3dState | SpatialModelState | Attempts to cast this model to a 3d geometric model. |
asSpatialModel Accessor Inherited ReadOnly | SpatialModelState | SpatialModelState | Attempts to cast this model to a spatial model. |
classFullName Accessor Static Inherited ReadOnly | string | SpatialModelState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly Inherited | string | SpatialModelState | The full class name in the form "schema:class". |
classifiers Readonly Inherited | SpatialClassifiersState | undefined | SpatialModelState | If this is a reality model, provides access to a list of available spatial classifiers that can be applied to it. |
className Accessor Inherited ReadOnly | string | SpatialModelState | The name of the BIS class associated with this class. |
id Readonly Inherited | string | SpatialModelState | The Id of this Entity. |
iModel Readonly Inherited | IModelConnection | SpatialModelState | The iModel from which this Entity was loaded |
is2d Accessor Inherited ReadOnly | boolean | SpatialModelState | Returns true if this is a 2d model (a GeometricModel2dState). |
is3d Accessor Inherited ReadOnly | boolean | SpatialModelState | Returns true if this is a 3d model (a GeometricModel3dState). |
isGeometricModel Accessor Inherited ReadOnly | boolean | SpatialModelState | Determine whether this is a GeometricModel |
isNotSpatiallyLocated Readonly Inherited | boolean | SpatialModelState | If true, then the elements in this GeometricModel3dState are not in real-world coordinates and will not be in the spatial index. |
isPlanProjection Readonly Inherited | boolean | SpatialModelState | If true, then the elements in this GeometricModel3dState are expected to be in an XY plane. |
isPrivate Readonly Inherited | boolean | SpatialModelState | |
isRealityModel Accessor Inherited ReadOnly | boolean | SpatialModelState | Return true if this is a reality model (represented by a 3d tile set). |
isSpatiallyLocated Accessor Inherited ReadOnly | boolean | SpatialModelState | If true, then the elements in this GeometricModel3dState are in real-world coordinates and will be in the spatial index. |
isTemplate Readonly Inherited | boolean | SpatialModelState | |
jsonProperties Readonly Inherited | { T } | SpatialModelState | Optional json properties of this Entity. |
modeledElement Readonly Inherited | RelatedElement | SpatialModelState | |
name Readonly Inherited | string | SpatialModelState | |
parentModel Inherited | string | SpatialModelState | |
schemaName Accessor Static Inherited ReadOnly | string | SpatialModelState | The name of the BIS schema for this class. |
Defined in
- core/frontend/src/ModelState.ts Line 294
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.