SheetModelState Class
Represents the front-end state of a SheetModel.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: GeometricModel2dProps, iModel: IModelConnection, state?: GeometricModel2dState): SheetModelState |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): this Inherited | GeometricModel2dState | Make an independent copy of this EntityState |
equals(other: this): boolean Inherited | GeometricModel2dState | Return true if this EntityState is equal to another one. |
queryModelRange(): Promise<Range3d> Inherited | GeometricModel2dState | Query for the union of the ranges of all the elements in this GeometricModel. |
toJSON(): GeometricModel2dProps Inherited | GeometricModel2dState | Add all custom-handled properties of a Model to a json object. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
asGeometricModel Accessor Inherited ReadOnly | GeometricModelState | GeometricModel2dState | Attempts to cast this model to a geometric model. |
asGeometricModel2d Accessor Inherited ReadOnly | GeometricModel2dState | GeometricModel2dState | Attempts to cast this model to a 2d geometric model. |
asGeometricModel3d Accessor Inherited ReadOnly | undefined | GeometricModel3dState | GeometricModel2dState | Attempts to cast this model to a 3d geometric model. |
asSpatialModel Accessor Inherited ReadOnly | undefined | SpatialModelState | GeometricModel2dState | Attempts to cast this model to a spatial model. |
classFullName Accessor Static Inherited ReadOnly | string | GeometricModel2dState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly Inherited | string | GeometricModel2dState | The full class name in the form "schema:class". |
className Accessor Inherited ReadOnly | string | GeometricModel2dState | The name of the BIS class associated with this class. |
id Readonly Inherited | string | GeometricModel2dState | The Id of this Entity. |
iModel Readonly Inherited | IModelConnection | GeometricModel2dState | The iModel from which this Entity was loaded |
is2d Accessor Inherited ReadOnly | boolean | GeometricModel2dState | Returns true if this is a 2d model (a GeometricModel2dState). |
is3d Accessor Inherited ReadOnly | boolean | GeometricModel2dState | Returns true if this is a 3d model (a GeometricModel3dState). |
isGeometricModel Accessor Inherited ReadOnly | boolean | GeometricModel2dState | Determine whether this is a GeometricModel |
isPrivate Readonly Inherited | boolean | GeometricModel2dState | |
isTemplate Readonly Inherited | boolean | GeometricModel2dState | |
jsonProperties Readonly Inherited | { T } | GeometricModel2dState | Optional json properties of this Entity. |
modeledElement Readonly Inherited | RelatedElement | GeometricModel2dState | |
name Readonly Inherited | string | GeometricModel2dState | |
parentModel Inherited | string | GeometricModel2dState | |
schemaName Accessor Static Inherited ReadOnly | string | GeometricModel2dState | The name of the BIS schema for this class. |
Defined in
- core/frontend/src/ModelState.ts Line 262
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.