EditableCatalogDb Interface
A writable CatalogDb.
@see openEditable to instantiate this type.
Extends
Methods
Name | Description | |
---|---|---|
updateCatalogManifest(manifest: CatalogIModel.Manifest): void | Update the contents of the catalog manifest. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
abandonChanges(): void Inherited | CatalogDb | Abandon changes in memory that have not been saved as a Txn to this iModelDb. |
acquireSchemaLock(): Promise<void> Inherited | CatalogDb | Acquire the exclusive schema lock on this iModel. |
attachDb(fileName: string, alias: string): void Inherited | CatalogDb | Attach an iModel file to this connection and load and register its schemas. |
clearCaches(): void Inherited | CatalogDb | Clear all in-memory caches held in this IModelDb. |
close(): void Inherited | CatalogDb | Close this IModel, if it is currently open, and save changes if it was opened in ReadWrite mode. |
computeProjectExtents(options?: ComputeProjectExtentsOptions): ComputedProjectExtents Inherited | CatalogDb | Compute an appropriate project extents for this iModel based on the ranges of all spatial elements. |
constructEntity<T extends Entity, P extends EntityProps>(props: P): T Inherited | CatalogDb | Construct an entity (Element or Model) from an iModel. |
containsClass(classFullName: string): boolean Inherited | CatalogDb | Query if this iModel contains the definition of the specified class. |
createClassViews(): void Inherited | CatalogDb | Creates or updates views in the iModel to permit visualizing the EC content as ECClasses and ECProperties rather than raw database tables and columns. |
createQueryReader(ecsql: string, params?: QueryBinder, config?: QueryOptions): ECSqlReader Inherited | CatalogDb | Allow to execute query and read results along with meta data. |
deleteFileProperty(prop: FilePropertyProps): void Inherited | CatalogDb | delete a "file property" from this iModel |
deleteSettingDictionary(name: string): void Inherited | CatalogDb | Delete a SettingDictionary, previously added with saveSettingDictionary, from this iModel. |
detachDb(alias: string): void Inherited | CatalogDb | Detach the attached file from this connection. |
elementGeometryCacheOperation(requestProps: ElementGeometryCacheOperationRequestProps): BentleyStatus Inherited | CatalogDb | Request operation using the backend geometry cache populated by first calling elementGeometryRequest. |
elementGeometryRequest(requestProps: ElementGeometryRequest): IModelStatus Inherited | CatalogDb | Request geometry stream information from an element in binary format instead of json. |
exportGraphics(exportProps: ExportGraphicsOptions): DbResult Inherited | CatalogDb | Export meshes suitable for graphics APIs from arbitrary geometry in elements in this IModelDb. |
exportPartGraphics(exportProps: ExportPartGraphicsOptions): DbResult Inherited | CatalogDb | Exports meshes suitable for graphics APIs from a specified GeometryPart |
exportSchema(args: ExportSchemaArgs): void Inherited | CatalogDb | Writes the contents of a single ECSchema to a file on the local file system. |
exportSchemas(outputDirectory: string): void Inherited | CatalogDb | Writes the contents of all ECSchemas in this iModel to files in a directory on the local file system. |
forEachMetaData(classFullName: string, wantSuper: boolean, func: PropertyCallback, includeCustom: booleantrue): void Inherited | CatalogDb | Invoke a callback on each property of the specified class, optionally including superclass properties. |
generateElementGraphics(request: ElementGraphicsRequestProps): Promise<undefined | Uint8Array> Inherited | CatalogDb | Generate graphics for an element or geometry stream. |
getBriefcaseId(): number Inherited | CatalogDb | Get the briefcase Id of this iModel |
getGeoCoordinatesFromIModelCoordinates(props: GeoCoordinatesRequestProps): Promise<GeoCoordinatesResponseProps> Inherited | CatalogDb | Get the GeoCoordinate (longitude, latitude, elevation) corresponding to each IModel Coordinate point in the input |
getGeometryContainment(props: GeometryContainmentRequestProps): Promise<GeometryContainmentResponseProps> Inherited | CatalogDb | Get the clip containment status for the supplied elements. |
getIModelCoordinatesFromGeoCoordinates(props: IModelCoordinatesRequestProps): Promise<IModelCoordinatesResponseProps> Inherited | CatalogDb | Get the IModel coordinate corresponding to each GeoCoordinate point in the input |
getInfo(): { manifest?: CatalogIModel.Manifest, version: string } Inherited | CatalogDb | Get the catalog's manifest and version. |
getJsClass<T extends >(classFullName: string): T Inherited | CatalogDb | Get the JavaScript class that handles a given entity class. |
getLastError(): string Inherited | CatalogDb | Returns a string representation of the error that most recently arose during an operation on the underlying SQLite database. |
getManifest(): undefined | CatalogIModel.Manifest Inherited | CatalogDb | Get the catalog's manifest. |
getMassProperties(props: MassPropertiesRequestProps): Promise<MassPropertiesResponseProps> Inherited | CatalogDb | Get the mass properties for the supplied elements. |
getMetaData(classFullName: string): EntityMetaData Inherited | CatalogDb | Get metadata for a class. |
getSchemaProps(name: string): ECSchemaProps Inherited | CatalogDb | Returns the full schema for the input name. |
getVersion(): string Inherited | CatalogDb | Get the catalog's version information. |
importSchemas(schemaFileNames: string[], options?: SchemaImportOptions): Promise<void> Inherited | CatalogDb | Import an ECSchema. |
inlineGeometryParts(): InlineGeometryPartsResult Inherited | CatalogDb | Attempts to optimize all of the geometry in this iModel by identifying GeometryParts that are referenced by exactly one |
isBriefcaseDb(): this is BriefcaseDb Inherited | CatalogDb | Type guard for instanceof BriefcaseDb |
isEditable(): this is EditableCatalogDb Inherited | CatalogDb | Returns true if the catalog was opened in read-write mode. |
isSnapshotDb(): this is SnapshotDb Inherited | CatalogDb | Type guard for instanceof SnapshotDb |
isStandaloneDb(): this is StandaloneDb Inherited | CatalogDb | Type guard for instanceof StandaloneDb. |
makeLockControl(): void Protected Inherited | CatalogDb | |
performCheckpoint(): void Inherited | CatalogDb | Save all changes and perform a checkpoint on this IModelDb. |
prepareStatement(sql: string, logErrors: booleantrue): ECSqlStatement Inherited | CatalogDb | Prepare an ECSQL statement. |
pullChanges(arg?: PullChangesArgs): Promise<void> Inherited | CatalogDb | Pull and apply changesets from iModelHub |
pushChanges(arg: PushChangesArgs): Promise<void> Inherited | CatalogDb | Push changes to iModelHub. |
queryEntityIds(params: EntityQueryParams): Id64Set Inherited | CatalogDb | Query for a set of entity ids, given an EntityQueryParams |
queryFilePropertyBlob(prop: FilePropertyProps): undefined | Uint8Array Inherited | CatalogDb | Query a "file property" from this iModel, as a blob. |
queryFilePropertyString(prop: FilePropertyProps): undefined | string Inherited | CatalogDb | Query a "file property" from this iModel, as a string. |
queryNextAvailableFileProperty(prop: FilePropertyProps): number Inherited | CatalogDb | Query for the next available major id for a "file property" from this iModel. |
querySchemaVersion(schemaName: string): undefined | string Inherited | CatalogDb | Query for a schema of the specified name in this iModel. |
revertAndPushChanges(arg: RevertChangesArgs): Promise<void> Inherited | CatalogDb | Revert timeline changes and then push resulting changeset |
saveChanges(description?: string): void Inherited | CatalogDb | Commit unsaved changes in memory as a Txn to this iModelDb. |
saveFileProperty(prop: FilePropertyProps, strValue: string, blobVal?: Uint8Array): void Inherited | CatalogDb | Save a "file property" to this iModel |
saveSettingDictionary(name: string, dict: SettingsContainer): void Inherited | CatalogDb | Save a SettingDictionary in this iModel that will be loaded into settings every time this iModel is opened in future sessions. |
simplifyElementGeometry(args: SimplifyElementGeometryArgs): IModelStatus Inherited | CatalogDb | Attempt to simplify the geometry stream of a single GeometricElement or GeometryPart as specified by args . |
tryGetMetaData(classFullName: string): undefined | EntityMetaData Inherited | CatalogDb | Identical to getMetaData, except it returns undefined instead of throwing an error if the metadata cannot be found nor loaded. |
tryPrepareStatement(sql: string): undefined | ECSqlStatement Inherited | CatalogDb | Prepare an ECSQL statement. |
updateEcefLocation(ecef: EcefLocation): void Inherited | CatalogDb | Update the EcefLocation of this iModel. |
updateElementGeometryCache(requestProps: ElementGeometryCacheRequestProps): Promise<ElementGeometryCacheResponseProps> Inherited | CatalogDb | Request the creation of a backend geometry cache for the specified geometric element. |
updateIModelProps(): void Inherited | CatalogDb | Update the IModelProps of this iModel in the database. |
updateProjectExtents(newExtents: Range3d): void Inherited | CatalogDb | Update the project extents for this iModel. |
withPreparedSqliteStatement<T>(sql: string, callback: (stmt: SqliteStatement) => T, logErrors: booleantrue): T Inherited | CatalogDb | Use a prepared SQL statement, potentially from the statement cache. |
withPreparedStatement<T>(ecsql: string, callback: (stmt: ECSqlStatement) => T, logErrors: booleantrue): T Inherited | CatalogDb | Use a prepared ECSQL statement, potentially from the statement cache. |
withSqliteStatement<T>(sql: string, callback: (stmt: SqliteStatement) => T, logErrors: booleantrue): T Inherited | CatalogDb | Prepared and execute a callback on a SQL statement. |
withStatement<T>(ecsql: string, callback: (stmt: ECSqlStatement) => T, logErrors: booleantrue): T Inherited | CatalogDb | Prepared and execute a callback on an ECSQL statement. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_fontMap Protected Inherited | FontMap | undefined | CatalogDb | |
briefcaseId Readonly Inherited | number | CatalogDb | |
channels Readonly Inherited | ChannelControl | CatalogDb | |
elements Readonly Inherited | IModelDb.Elements | CatalogDb | |
models Readonly Inherited | IModelDb.Models | CatalogDb | |
onBeforeClose Readonly Inherited | BeEvent<() => void> | CatalogDb | Event called when the iModel is about to be closed. |
onChangesetApplied Readonly Inherited | BeEvent<() => void> | CatalogDb | Event called after a changeset is applied to this IModelDb. |
onClosed Readonly Inherited | BeEvent<() => void> | CatalogDb | Event raised after a BriefcaseDb has been closed. |
tiles Readonly Inherited | IModelDb.Tiles | CatalogDb | |
txns Readonly Inherited | TxnManager | CatalogDb | Manages local changes to this briefcase. |
views Readonly Inherited | IModelDb.Views | CatalogDb | |
cloudContainer Accessor Inherited ReadOnly | undefined | CloudSqlite.CloudContainer | CatalogDb | get the cloud container for this iModel, if it was opened from one |
codeSpecs Accessor Inherited ReadOnly | CodeSpecs | CatalogDb | Get the CodeSpecs in this IModel. |
codeValueBehavior Accessor Inherited | "exact" | "trim-unicode-whitespace" | CatalogDb | Controls how Codes are copied from this iModel into another iModel, to work around problems with iModels created by older connectors. The imodel-transformer sets this appropriately on your behalf - you should never need to set or interrogate this property yourself. |
fontMap Accessor Inherited ReadOnly | FontMap | CatalogDb | |
fonts Accessor Inherited ReadOnly | IModelDbFonts | CatalogDb | Provides methods for interacting with font-related information stored in this iModel. |
holdsSchemaLock Accessor Inherited ReadOnly | boolean | CatalogDb | determine whether the schema lock is currently held for this iModel. |
iModelId Accessor Inherited ReadOnly | string | CatalogDb | The Guid that identifies this iModel. |
isBriefcase Accessor Inherited ReadOnly | boolean | CatalogDb | override superclass method |
isReadonly Accessor Inherited ReadOnly | boolean | CatalogDb | Check if this iModel has been opened read-only or not. |
isSnapshot Accessor Inherited ReadOnly | boolean | CatalogDb | Returns true if this is a SnapshotDb |
iTwinId Accessor Inherited ReadOnly | string | CatalogDb | The Guid that identifies the context that owns this iModel. GuidString | undefined for the superclass, but required for BriefcaseDb |
jsClassMap Accessor Inherited ReadOnly | EntityJsClassMap | CatalogDb | Allows registering js classes mapped to ECClasses |
locks Accessor Inherited ReadOnly | LockControl | CatalogDb | The LockControl that orchestrates concurrent editing of this iModel. |
pathName Accessor Inherited ReadOnly | string | CatalogDb | Get the full path fileName of this iModelDb |
relationships Accessor Inherited ReadOnly | Relationships | CatalogDb | Get the linkTableRelationships for this IModel |
schemaContext Accessor Inherited ReadOnly | SchemaContext | CatalogDb | Gets the context that allows accessing the metadata (ecschema-metadata package) of this iModel |
schemaMap Accessor Inherited ReadOnly | SchemaMap | CatalogDb | Allows locally registering a schema for this imodel, in constrast to [Schemas.registerSchema] which is a global operation |
useLockServer Accessor Protected Inherited ReadOnly | boolean | CatalogDb | Determine whether this BriefcaseDb should use a lock server. All must be true: - file is open for write - has an assigned briefcaseId - the "no locking" flag is not present. This is a property of an iModel, established when the iModel is created in IModelHub. |
workspace Accessor Inherited ReadOnly | Workspace | CatalogDb | Get the Workspace for this iModel. |
Defined in
- core/backend/src/CatalogDb.ts Line 100
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.