FontMap Class
Deprecated in 5.0.0. Use IModelDb.fonts instead.
A FontMap holds the set of font names available in an iModel. Within the GeometryStream of an Element, a specific font is referenced by its FontId that is local to the iModel. This class maps FontIds to FontProps.
@note This API has never worked properly. Don't use it. Use IModelDb.fonts instead.
Methods
Name | Description | |
---|---|---|
constructor(props?: FontMapProps): FontMap | ||
addFonts(fonts: FontProps[]): void | ||
getFont(arg: string | number): undefined | FontProps | look up a font by case insensitive name or number and return its FontProps | |
toJSON(): FontMapProps |
Properties
Name | Type | Description | |
---|---|---|---|
fonts Readonly | Map<number, FontProps> |
Defined in
- core/common/src/Fonts.ts Line 113
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.