IModelDbFonts Interface

Provides read-write access to the font-related information stored in an IModelDb.

@see IModelDb.fonts to access the fonts for a specific iModel.

Methods

Name Description
acquireId(descriptor: FontFamilyDescriptor): Promise<number> Look up the Id assigned to the specified font family, allocating a new Id if one has not already been assigned.  
embedFontFile(args: EmbedFontFileArgs): Promise<void> Store a FontFile in the iModel.  
findDescriptor(id: number): undefined | FontFamilyDescriptor Returns the font family associated with the specified Id, or undefined if no such mapping exists.  
findId(selector: FontFamilySelector): undefined | number Returns the Id assigned to the specified font family, or undefined if no Id has been assigned.  
queryEmbeddedFontFiles(): Iterable<FontFile, any, any> Obtain the collection of FontFiles embedded in the iModel.  
queryMappedFamilies(args?: QueryMappedFamiliesArgs): Iterable<FontProps, any, any> Obtain the collection of font families that have been assigned a FontId.  

Defined in

Last Updated: 18 January, 2025