FontFamilySelector Interface

A FontFamilyDescriptor in which the FontType is optional, used when querying FontIds via IModelDbFonts.findId. If a font type is provided, this selector exactly identifies a unique font family, just like FontFamilyDescriptor does. If the type is omitted, then the selector refers to the first font family that matches the specified name. If multiple families with the same name exist, then a TrueType font will be preferred over a RSC font, and a RSC font preferred over an SHX font.

Properties

Name Type Description
name string The name of the family.  
type FontType | undefined The encoding in which the font family's faces are stored.  

Defined in

Last Updated: 18 January, 2025