FontType Enumeration

The FontFile encodings understood by iTwin.js.

@see this article to learn more about fonts in iModels.

Members

Name Value Description
Rsc RSC is a simple font format
originating in MicroStation. In MicroStation, they are defined in "resource files" with a ".rsc" suffix.
In iModels, they are encoded in a binary format. Currently, no APIs exist to convert to this binary format, but some connectors can
perform the conversion.
Shx SHX is a simple font format originating in
AutoCAD. SHX fonts are generally distributed as files with a ".shx" suffix.

@see FontFile.createFromShxFontBlob to work with font files in this format.
TrueType OpenType format, derived from and compatible with the earlier TrueType format.
The vast majority of modern, scalable, aesthetically-pleasing fonts are delivered in this format.
OpenType files typically use one of the following suffixes: .ttf, .ttc, .otf, and .otc.

@see FontFile.createFromTrueTypeFileName to work with font files in this format.

Defined in

Last Updated: 18 January, 2025