FontFile Namespace
Function
Name | Description |
---|---|
FontFile.createFromShxFontBlob | Create a FontFile from the binary representation of a FontType.SHX font face. |
FontFile.createFromTrueTypeFileName | Create a FontFile from a FontType.TrueType file on disk. |
Defined in
- core/backend/src/FontFile.ts Line 20
FontFile Interface
A container for one or more font faces, often originating as a file on disk.
@see - createFromTrueTypeFileName and createFromShxFontBlob to create a font file.
- queryEmbeddedFontFiles to obtain font files embedded in an IModelDb.
- embedFontFile to embed a font file into an IModelDb.
Properties
Name | Type | Description | |
---|---|---|---|
faces Readonly | ReadonlyArray<Readonly<FontFace>> | The individual faces encoded into the file. | |
isEmbeddable Readonly | boolean | If false, the font is not licensed for embedding, and attempting to embed it into an iModel will throw an error. | |
type Readonly | FontType | The format in which the font data is encoded. |
Defined in
- core/backend/src/FontFile.ts Line 20
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.