GeometricElement2d Class

An abstract base class to model information entities that intrinsically have 2d geometry.

Extends

Extended by

Methods

Name Description
constructor(props: GeometricElement2dProps, iModel: IModelDb): GeometricElement2d Protected    
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Collect the Ids of this entity's references at this level of the class hierarchy.  
toJSON(): GeometricElement2dProps Obtain the JSON representation of this Entity.  

Inherited methods

Name Inherited from Description
calculateRange3d(): Range3d Inherited GeometricElement  
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited GeometricElement Collect the Ids of this element's references at this level of the class hierarchy.
delete(): void Inherited GeometricElement Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited GeometricElement Call a function for each property of this Entity.
GeometricElement Get the class metadata for this element.
getDisplayLabel(): string Inherited GeometricElement Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited GeometricElement Get a JSON property of this element, by namespace
getPlacementTransform(): Transform Inherited GeometricElement Get the Transform from the Placement of this GeometricElement
getPredecessorIds(): Id64Set Inherited GeometricElement Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited GeometricElement Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited GeometricElement Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited GeometricElement Get a set of JSON user properties by namespace
insert(): string Inherited GeometricElement Insert this Element into the iModel.
is2d(): this is GeometricElement2d Inherited GeometricElement Type guard for instanceof GeometricElement2d
is3d(): this is GeometricElement3d Inherited GeometricElement Type guard for instanceof GeometricElement3d
removeUserProperties(nameSpace: string): void Inherited GeometricElement Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void Inherited GeometricElement  
setUserProperties(nameSpace: string, value: any): void Inherited GeometricElement Change a set of user JSON properties of this Element by namespace.
update(): void Inherited GeometricElement Update this Element in the iModel.
is(otherClass: ): boolean Static Inherited GeometricElement return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited GeometricElement Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited GeometricElement Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited GeometricElement Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited GeometricElement Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited GeometricElement Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited GeometricElement Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void Protected Static Inherited GeometricElement Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited GeometricElement Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited GeometricElement Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited GeometricElement Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited GeometricElement Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited GeometricElement Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited GeometricElement Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited GeometricElement Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited GeometricElement Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited GeometricElement Called after an Element was updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  
placement Placement2d The origin, orientation, and bounding box of this GeometricElement.  
typeDefinition TypeDefinition | undefined    

Inherited properties

Name Type Inherited from Description
category Inherited string GeometricElement The Id of the Category for this GeometricElement.
classFullName Accessor Inherited ReadOnly string GeometricElement Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string GeometricElement Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string GeometricElement The name of the BIS class associated with this class.
code Inherited Code GeometricElement The Code for this element
elementGeometryBuilderParams Inherited ElementGeometryBuilderParams | undefined GeometricElement How to build the element's GeometryStream.
federationGuid Inherited string | undefined GeometricElement A FederationGuid assigned to this element by some other federated database
geom Inherited GeometryStreamProps | undefined GeometricElement The GeometryStream for this GeometricElement.
id Inherited string GeometricElement The Id of this Entity.
iModel Inherited IModelDb GeometricElement The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" GeometricElement An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
jsonProperties Readonly Inherited { T } GeometricElement Optional json properties of this element.
model Readonly Inherited string GeometricElement The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined GeometricElement The parent element, if present, of this element.
requiredReferenceKeys Static Readonly Inherited ReadonlyArray GeometricElement  
schema Static Inherited GeometricElement The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string GeometricElement The name of the BIS Schema that defines this class
userLabel Inherited string | undefined GeometricElement A user-assigned label for this element.

Defined in

Last Updated: 21 November, 2024