ExternalSourceAttachment Class

Attachment of an ExternalSource

@note The associated ECClass was added to the BisCore schema in version 1.0.13

Extends

Methods

Name Description
constructor(props: ExternalSourceAttachmentProps, iModel: IModelDb): ExternalSourceAttachment Protected    
toJSON(): ExternalSourceAttachmentProps    
createCode(iModelDb: IModelDb, scopeElementId: string, codeValue: string): Code Static Create a Code for an ExternalSourceAttachment element given a name that is meant to be unique within the scope of its parent ExternalSource.  
ensureCodeSpec(iModelDb: IModelDb): string Static The CodeSpec for ExternalSourceAttachment elements is not automatically created, so this method ensures that it exists.  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited InformationReferenceElement Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited InformationReferenceElement Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited InformationReferenceElement Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited InformationReferenceElement Call a function for each property of this Entity.
InformationReferenceElement Get the class metadata for this element.
getDisplayLabel(): string Inherited InformationReferenceElement Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited InformationReferenceElement Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set Inherited InformationReferenceElement Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited InformationReferenceElement Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited InformationReferenceElement Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited InformationReferenceElement Get a set of JSON user properties by namespace
insert(): string Inherited InformationReferenceElement Insert this Element into the iModel.
removeUserProperties(nameSpace: string): void Inherited InformationReferenceElement Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void Inherited InformationReferenceElement  
setUserProperties(nameSpace: string, value: any): void Inherited InformationReferenceElement Change a set of user JSON properties of this Element by namespace.
update(): void Inherited InformationReferenceElement Update this Element in the iModel.
is(otherClass: ): boolean Static Inherited InformationReferenceElement return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited InformationReferenceElement Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited InformationReferenceElement Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited InformationReferenceElement Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited InformationReferenceElement Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited InformationReferenceElement Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited InformationReferenceElement Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited InformationReferenceElement Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited InformationReferenceElement Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited InformationReferenceElement Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited InformationReferenceElement Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited InformationReferenceElement Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited InformationReferenceElement Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited InformationReferenceElement Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void Protected Static Inherited InformationReferenceElement Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited InformationReferenceElement Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited InformationReferenceElement Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited InformationReferenceElement Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited InformationReferenceElement Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited InformationReferenceElement Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited InformationReferenceElement Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited InformationReferenceElement Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited InformationReferenceElement Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited InformationReferenceElement Called after an Element was updated.

Properties

Name Type Description
attaches ExternalSourceAttachmentAttachesSource | undefined The ExternalSource that is attached by this ExternalSourceAttachment.  
pitch number | undefined The Pitch angle (in degrees) of the attached ExternalSource relative to the ExternalSource that attaches it.  
role ExternalSourceAttachmentRole | undefined Specifies whether the attached ExternalSource provides context or models a part of the whole.  
roll number | undefined The Roll angle (in degrees) of the attached ExternalSource relative to the ExternalSource that attaches it.  
scale Point3d | undefined The scale of the attached ExternalSource relative to the ExternalSource that attaches it.  
translation Point3d | undefined The translation or offset in global coordinates of the attached ExternalSource relative to the ExternalSource that attaches it.  
yaw number | undefined The Yaw angle (in degrees) of the attached ExternalSource relative to the ExternalSource that attaches it.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string InformationReferenceElement Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string InformationReferenceElement Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string InformationReferenceElement The name of the BIS class associated with this class.
code Inherited Code InformationReferenceElement The Code for this element
federationGuid Inherited string | undefined InformationReferenceElement A FederationGuid assigned to this element by some other federated database
id Inherited string InformationReferenceElement The Id of this Entity.
iModel Inherited IModelDb InformationReferenceElement The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" InformationReferenceElement An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
jsonProperties Readonly Inherited { T } InformationReferenceElement Optional json properties of this element.
model Readonly Inherited string InformationReferenceElement The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined InformationReferenceElement The parent element, if present, of this element.
requiredReferenceKeys Static Readonly Inherited ReadonlyArray InformationReferenceElement A required reference is an element that had to be inserted before this element could have been inserted.
schema Static Inherited InformationReferenceElement The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string InformationReferenceElement The name of the BIS Schema that defines this class
userLabel Inherited string | undefined InformationReferenceElement A user-assigned label for this element.

Defined in

Last Updated: 21 November, 2024