InspectElementTool Class

Creates a readable text summary of a geometric element or geometry part. The keyin takes the following arguments, all of which are optional:

  • id=elementId,elementId,elementId comma-separated list of element Ids where each elementId is a hexadecimal element Id such as "0x12cb";
  • symbology=0|1 where 1 indicates detailed symbology information should be included in the output;
  • placement=0|1 where 1 indicates detailed geometric element placement should be included; and
  • verbosity=0|1|2 controlling the verbosity of the output for each geometric primitive in the geometry stream. Higher values = more detailed information. Note verbosity=2 can produce megabytes of data for certain types of geometric primitives like large meshes.
  • modal=0|1 where 1 indicates the output should appear in a modal dialog.
  • copy=0|1 where 1 indicates the output should be copied to the clipboard. Defaults to true.
  • refs=0|1 where 1 indicates that for geometry parts a list of all elements referencing that part should be included in the output. This is extremely computationally expensive. If no id is specified, the tool runs in interactive mode: first operating upon the selection set (if any), then allowing the user to select additional elements.

Extends

Methods

Name Description
constructor(options?: GeometrySummaryOptions, elementIds?: string[]): InspectElementTool    
autoLockTarget(): void Called on data button down event to lock the tool to its current target model.  
filterHit(hit: HitDetail, _out: LocateResponse): Promise<LocateFilterStatus> Invoked to allow tools to filter which elements can be located.  
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> Invoked when the data button is pressed.  
onPostInstall(): Promise<void> Override to execute additional logic after tool becomes active  
onReinitialize(): Promise<void> Called to reset tool to initial state.  
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Invoked when the reset button is released.  
onRestartTool(): Promise<void> Called when an external event may invalidate the current tool's state.  
onUnsuspend(): Promise<void> Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended.  
parseAndRun(...inputArgs: string[]): Promise<boolean> Run this instance of a tool using a series of string arguments.  
requireWriteableTarget(): boolean Called from isCompatibleViewport to check for a read only iModel, which is not a valid target for tools that create or modify elements.  

Inherited methods

Name Inherited from Description
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited PrimitiveTool Used to receive property changes from UI.
beginDynamics(): void Inherited PrimitiveTool Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited PrimitiveTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited PrimitiveTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited PrimitiveTool Helper method for responding to a tool setting property value change by updating saved settings.
decorate(_context: DecorateContext): void Inherited PrimitiveTool Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void Inherited PrimitiveTool Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void Inherited PrimitiveTool Call to terminate dynamics mode.
exitTool(): Promise<void> Inherited PrimitiveTool  
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited PrimitiveTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited PrimitiveTool Called to allow snapping to pickable decoration geometry.
getPrompt(): string Inherited PrimitiveTool Returns the prompt based on the tool's current state.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited PrimitiveTool Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited PrimitiveTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited PrimitiveTool Helper method to establish initial values for tool setting properties from saved settings.
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited PrimitiveTool Helper method for tools that need to locate existing elements.
isCompatibleViewport(vp: Viewport, isSelectedViewChange: boolean): boolean Inherited PrimitiveTool Determine whether the supplied Viewport is compatible with this tool.
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean Inherited PrimitiveTool Checks that the adjusted point from the supplied button event is within the project extents for spatial views.
onCleanup(): Promise<void> Inherited PrimitiveTool Invoked when the tool becomes no longer active, to perform additional cleanup logic
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited PrimitiveTool Called to allow Tool to display dynamic elements.
onInstall(): Promise<boolean> Inherited PrimitiveTool Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited PrimitiveTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited PrimitiveTool Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the button is released after onMouseStartDrag.
onMouseMotion(_ev: BeButtonEvent): Promise<void> Inherited PrimitiveTool Invoked when the cursor is moving
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the mouse wheel moves.
onRedoPreviousStep(): Promise<boolean> Inherited PrimitiveTool Called to reinstate to a previous tool state (ex.
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited PrimitiveTool Invoked when the reset button is pressed.
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> Inherited PrimitiveTool Called when active view changes.
onSuspend(): Promise<void> Inherited PrimitiveTool Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchCancel(_ev: BeTouchEvent): Promise<void> Inherited PrimitiveTool Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.
onTouchComplete(_ev: BeTouchEvent): Promise<void> Inherited PrimitiveTool Called when the last touch point is removed from the surface completing the current gesture.
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited PrimitiveTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(_ev: BeTouchEvent): Promise<void> Inherited PrimitiveTool Called when a touch point moves along the surface.
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> Inherited PrimitiveTool Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited PrimitiveTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited PrimitiveTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUndoPreviousStep(): Promise<boolean> Inherited PrimitiveTool Called to reverse to a previous tool state (ex.
reloadToolSettingsProperties(): void Inherited PrimitiveTool Called by tool to inform UI to reload ToolSettings with new set of properties.
run(..._args: any[]): Promise<boolean> Inherited PrimitiveTool Establish this tool as the active PrimitiveTool.
saveChanges(): Promise<void> Inherited PrimitiveTool If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string.
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited PrimitiveTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited PrimitiveTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean Inherited PrimitiveTool Called to support operations on pickable decorations, like snapping.
register(namespace?: string): void Static Inherited PrimitiveTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
maxArgs Accessor Static ReadOnly number The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.  
minArgs Accessor Static ReadOnly number The minimum number of arguments allowed by parseAndRun.  
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
briefcase Accessor Inherited ReadOnly undefined | BriefcaseConnection PrimitiveTool Get the briefcase on which this tool operates, if the tool has successfully installed and the target PrimitiveTool.iModel is a briefcase.
description Accessor Inherited ReadOnly string PrimitiveTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string PrimitiveTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
PrimitiveTool.flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string PrimitiveTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string PrimitiveTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string PrimitiveTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
PrimitiveTool.keyin is returned.
hidden Static Inherited boolean PrimitiveTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string PrimitiveTool Get the iconSpec from this Tool's class.
iconSpec Static Inherited string PrimitiveTool The icon for this Tool.
iModel Accessor Inherited ReadOnly IModelConnection PrimitiveTool Get the iModel on which this tool operates.
isControlDown Accessor Inherited ReadOnly boolean PrimitiveTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor Inherited ReadOnly boolean PrimitiveTool Call to find out if dynamics are currently active.
keyin Accessor Inherited ReadOnly string PrimitiveTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string PrimitiveTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
namespace Static Inherited string PrimitiveTool The namespace that provides localized strings for this Tool.
receivedDownEvent Inherited boolean PrimitiveTool Used to avoid sending tools up events for which they did not receive the down event.
targetIsLocked Inherited boolean PrimitiveTool  
targetModelId Accessor Inherited undefined | string PrimitiveTool  
targetView Inherited Viewport | undefined PrimitiveTool The viewport within which the tool operates.
toolId Accessor Inherited ReadOnly string PrimitiveTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 21 November, 2024