LookViewTool Class

A tool that performs the look operation

Extends

Methods

Name Description
constructor(vp: ScreenViewport, oneShot: booleanfalse, isDraggingRequired: booleanfalse): LookViewTool    
onReinitialize(): Promise<void> Override Call to reset tool to initial state  

Inherited methods

Name Inherited from Description
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited ViewManip Used to receive property changes from UI.
beginDynamics(): void Inherited ViewManip Call to initialize dynamics mode.
beginDynamicUpdate(): void Inherited ViewManip  
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited ViewManip Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited ViewManip Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with isLocateEnabled and isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited ViewManip Helper method for responding to a tool setting property value change by updating saved settings.
changeViewport(vp?: ScreenViewport): void Inherited ViewManip  
decorate(context: DecorateContext): void Inherited ViewManip Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void Inherited ViewManip Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void Inherited ViewManip Call to terminate dynamics mode.
endDynamicUpdate(): void Inherited ViewManip  
enforceZUp(pivotPoint: Point3d): boolean Inherited ViewManip  
exitTool(): Promise<void> Inherited ViewManip Do not override.
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> Inherited ViewManip Invoked to allow tools to filter which elements can be located.
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited ViewManip Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited ViewManip Called to allow snapping to pickable decoration geometry.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited ViewManip Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited ViewManip Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited ViewManip Helper method to establish initial values for tool setting properties from saved settings.
initLocateElements(enableLocate: booleantrue, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited ViewManip Helper method for tools that need to locate existing elements.
isCompatibleViewport(_vp: ScreenViewport, _isSelectedViewChange: boolean): boolean Inherited ViewManip  
isPointVisible(testPt: Point3d): boolean Inherited ViewManip Determine whether the supplied point is visible in this Viewport.
isValidLocation(_ev: BeButtonEvent, _isButtonEvent: boolean): boolean Inherited ViewManip  
lensAngleMatches(angle: Angle, tolerance: number): boolean Inherited ViewManip  
onCleanup(): Promise<void> Inherited ViewManip Invoked when the tool becomes no longer active, to perform additional cleanup logic
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> Inherited ViewManip Invoked when the data button is pressed.
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewManip Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited ViewManip Called to allow Tool to display dynamic elements.
onInstall(): Promise<boolean> Inherited ViewManip Override to execute additional logic when tool is installed.
onKeyTransition(wentDown: boolean, keyEvent: KeyboardEvent): Promise<EventHandled> Inherited ViewManip Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewManip Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewManip Invoked when the middle mouse button is released.
onModifierKeyTransition(wentDown: boolean, modifier: BeModifierKeys, event: KeyboardEvent): Promise<EventHandled> Inherited ViewManip Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited ViewManip Invoked when the button is released after onMouseStartDrag.
onMouseMotion(ev: BeButtonEvent): Promise<void> Inherited ViewManip Invoked when the cursor is moving
onMouseStartDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited ViewManip Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(inputEv: BeWheelEvent): Promise<EventHandled> Inherited ViewManip Invoked when the mouse wheel moves.
onPostInstall(): Promise<void> Inherited ViewManip Override to execute additional logic after tool becomes active
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewManip Invoked when the reset button is pressed.
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewManip Invoked when the reset button is released.
onSelectedViewportChanged(_previous: ScreenViewport, _current: ScreenViewport): void Inherited ViewManip Called when active view changes.
onSuspend(): Promise<void> Inherited ViewManip Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchCancel(ev: BeTouchEvent): Promise<void> Inherited ViewManip Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.
onTouchComplete(ev: BeTouchEvent): Promise<void> Inherited ViewManip Called when the last touch point is removed from the surface completing the current gesture.
onTouchEnd(ev: BeTouchEvent): Promise<void> Inherited ViewManip Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(ev: BeTouchEvent): Promise<void> Inherited ViewManip Called when a touch point moves along the surface.
onTouchMoveStart(ev: BeTouchEvent, startEv: BeTouchEvent): Promise<EventHandled> Inherited ViewManip Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(ev: BeTouchEvent): Promise<void> Inherited ViewManip Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(ev: BeTouchEvent): Promise<EventHandled> Inherited ViewManip Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUnsuspend(): Promise<void> Inherited ViewManip Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended.
parseAndRun(..._args: string[]): Promise<boolean> Inherited ViewManip Run this instance of a tool using a series of string arguments.
processFirstPoint(ev: BeButtonEvent): boolean Inherited ViewManip  
processPoint(ev: BeButtonEvent, inDynamics: boolean): boolean Inherited ViewManip  
provideToolAssistance(mainInstrKey: string, additionalInstr?: ToolAssistanceInstruction[]): void Inherited ViewManip  
reloadToolSettingsProperties(): void Inherited ViewManip Called by tool to inform UI to reload ToolSettings with new set of properties.
run(..._args: any[]): Promise<boolean> Inherited ViewManip Run this instance of a Tool.
setCameraLensAngle(lensAngle: Angle, retainEyePoint: boolean): ViewStatus Inherited ViewManip  
setTargetCenterWorld(pt: Point3d, lockTarget: boolean, saveTarget: boolean): void Inherited ViewManip Set the center of rotation for rotate handle.
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited ViewManip Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited ViewManip Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean Inherited ViewManip Called to support operations on pickable decorations, like snapping.
updateTargetCenter(): void Inherited ViewManip  
fitView(viewport: ScreenViewport, animateFrustumChange: boolean, options?: ViewChangeOptions & MarginOptions): void Static Inherited ViewManip  
getDefaultTargetPointWorld(vp: Viewport): Point3d Static Inherited ViewManip  
getFocusPlaneNpc(vp: Viewport): number Static Inherited ViewManip  
register(namespace?: string): void Static Inherited ViewManip Register this Tool class with the ToolRegistry.
showPrompt(prompt: string): void Static Inherited ViewManip  
translate(val: string): string Static Inherited ViewManip  
zoomToAlwaysDrawnExclusive(viewport: ScreenViewport, options?: ViewChangeOptions & MarginOptions): Promise<boolean> Static Inherited ViewManip  

Properties

Name Type Description
iconSpec Static string The icon for this Tool.  
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
description Accessor Inherited ReadOnly string ViewManip Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string ViewManip Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string ViewManip Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string ViewManip Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string ViewManip Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
frustumValid Inherited boolean ViewManip  
handleMask Inherited number ViewManip  
hidden Static Inherited boolean ViewManip If true, this Tool will not appear in the list from getToolList.
iconSpec Accessor Inherited ReadOnly string ViewManip Get the iconSpec from this Tool's class.
inDynamicUpdate Inherited boolean ViewManip  
inHandleModify Inherited boolean ViewManip  
isControlDown Accessor Inherited ReadOnly boolean ViewManip Convenience method to check whether control key is currently down without needing a button event.
isDragging Inherited boolean ViewManip  
isDraggingRequired Inherited boolean ViewManip  
isDynamicsStarted Accessor Inherited ReadOnly boolean ViewManip Call to find out if dynamics are currently active.
isZUp Accessor Inherited ReadOnly boolean ViewManip  
keyin Accessor Inherited ReadOnly string ViewManip Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string ViewManip Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor Static Inherited ReadOnly undefined | number ViewManip The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.
If subclasses override parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number ViewManip The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string ViewManip The namespace that provides localized strings for this Tool.
nPts Inherited number ViewManip  
oneShot Inherited boolean ViewManip  
receivedDownEvent Inherited boolean ViewManip Used to avoid sending tools up events for which they did not receive the down event.
targetCenterLocked Inherited boolean ViewManip  
targetCenterValid Inherited boolean ViewManip  
targetCenterWorld Readonly Inherited Point3d ViewManip  
toolId Accessor Inherited ReadOnly string ViewManip Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.
viewport Inherited ScreenViewport | undefined ViewManip  

Defined in

Last Updated: 21 November, 2024