EditManipulator.HandleTool Class

Interactive control handle modification is done by installing an InputCollector. Modification typically is started from a click or press and drag while over the handle graphics. The HandleTool base class is set up to define an offset by 2 points. The second point is defined by either another click, or up event when initiated from press and drag.

@see HandleProvider

Extends

Methods

Name Description
constructor(manipulator: EditManipulator.HandleProvider): EditManipulator.HandleTool    
accept(_ev: BeButtonEvent): boolean Protected Abstract Called from data button down event to check if enough input has been gathered to complete the modification.  
cancel(_ev: BeButtonEvent): boolean Protected Called from reset button up event to allow modification to be cancelled.  
init(): void Protected Establish the initial tool state for handle modification.  
onComplete(_ev: BeButtonEvent, event: EditManipulator.EventType): Promise<EventHandled> Protected Called following cancel or accept to update the handle provider  
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> Invoked when the data button is pressed.  
onPostInstall(): Promise<void> Override to execute additional logic after tool becomes active  
onResetButtonUp(ev: BeButtonEvent): Promise<EventHandled> Invoked when the reset button is released.  
onTouchCancel(ev: BeTouchEvent): Promise<void> Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.  
onTouchComplete(ev: BeTouchEvent): Promise<void> Called when the last touch point is removed from the surface completing the current gesture.  
onTouchMove(ev: BeTouchEvent): Promise<void> Called when a touch point moves along the surface.  

Inherited methods

Name Inherited from Description
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited InputCollector Used to receive property changes from UI.
beginDynamics(): void Inherited InputCollector Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited InputCollector Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited InputCollector Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with isLocateEnabled and isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited InputCollector Helper method for responding to a tool setting property value change by updating saved settings.
decorate(_context: DecorateContext): void Inherited InputCollector Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void Inherited InputCollector Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void Inherited InputCollector Call to terminate dynamics mode.
exitTool(): Promise<void> Inherited InputCollector  
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> Inherited InputCollector Invoked to allow tools to filter which elements can be located.
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited InputCollector Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited InputCollector Called to allow snapping to pickable decoration geometry.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited InputCollector Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited InputCollector Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited InputCollector Helper method to establish initial values for tool setting properties from saved settings.
initLocateElements(enableLocate: booleantrue, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited InputCollector Helper method for tools that need to locate existing elements.
isCompatibleViewport(_vp: ScreenViewport, _isSelectedViewChange: boolean): boolean Inherited InputCollector  
isValidLocation(_ev: BeButtonEvent, _isButtonEvent: boolean): boolean Inherited InputCollector  
onCleanup(): Promise<void> Inherited InputCollector Invoked when the tool becomes no longer active, to perform additional cleanup logic
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited InputCollector Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited InputCollector Called to allow Tool to display dynamic elements.
onInstall(): Promise<boolean> Inherited InputCollector Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited InputCollector Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited InputCollector Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited InputCollector Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited InputCollector Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited InputCollector Invoked when the button is released after onMouseStartDrag.
onMouseMotion(_ev: BeButtonEvent): Promise<void> Inherited InputCollector Invoked when the cursor is moving
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> Inherited InputCollector Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited InputCollector Invoked when the mouse wheel moves.
onReinitialize(): Promise<void> Inherited InputCollector Override Call to reset tool to initial state
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited InputCollector Invoked when the reset button is pressed.
onSelectedViewportChanged(_previous: ScreenViewport, _current: ScreenViewport): void Inherited InputCollector Called when active view changes.
onSuspend(): Promise<void> Inherited InputCollector Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited InputCollector Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> Inherited InputCollector Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited InputCollector Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited InputCollector Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUnsuspend(): Promise<void> Inherited InputCollector Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended.
parseAndRun(..._args: string[]): Promise<boolean> Inherited InputCollector Run this instance of a tool using a series of string arguments.
reloadToolSettingsProperties(): void Inherited InputCollector Called by tool to inform UI to reload ToolSettings with new set of properties.
run(..._args: any[]): Promise<boolean> Inherited InputCollector Run this instance of a Tool.
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited InputCollector Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited InputCollector Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean Inherited InputCollector Called to support operations on pickable decorations, like snapping.
register(namespace?: string): void Static Inherited InputCollector Register this Tool class with the ToolRegistry.

Properties

Name Type Description
hidden Static boolean If true, this Tool will not appear in the list from getToolList.  
manipulator Readonly EditManipulator.HandleProvider    
toolId Static string The unique string that identifies this tool.  
wantAccuSnap Accessor Protected ReadOnly boolean Whether to call enableSnap for handle modification.  

Inherited properties

Name Type Inherited from Description
description Accessor Inherited ReadOnly string InputCollector Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string InputCollector Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string InputCollector Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string InputCollector Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string InputCollector Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
iconSpec Accessor Inherited ReadOnly string InputCollector Get the iconSpec from this Tool's class.
iconSpec Static Inherited string InputCollector The icon for this Tool.
isControlDown Accessor Inherited ReadOnly boolean InputCollector Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor Inherited ReadOnly boolean InputCollector Call to find out if dynamics are currently active.
keyin Accessor Inherited ReadOnly string InputCollector Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string InputCollector Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor Static Inherited ReadOnly undefined | number InputCollector The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.
If subclasses override parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number InputCollector The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string InputCollector The namespace that provides localized strings for this Tool.
receivedDownEvent Inherited boolean InputCollector Used to avoid sending tools up events for which they did not receive the down event.
toolId Accessor Inherited ReadOnly string InputCollector Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 21 November, 2024