CustomGraphicBuilderOptions Interface
Options for creating a GraphicBuilder to produce a RenderGraphic or GraphicTemplate that is not associated with any particular Viewport and may not be associated with any particular IModelConnection. This is primarily useful when the same graphic is to be saved and reused for display in multiple viewports and for which a chord tolerance can be computed independently of each viewport's Frustum.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
applyAspectRatioSkew | undefined | undefined | ||
computeChordTolerance | (args: ComputeChordToleranceArgs) => number | A function that can compute the level of detail for the graphics produced by the builder. | |
iModel | IModelConnection | undefined | Optionally, the IModelConnection with which the graphic is associated. | |
viewport | undefined | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
generateEdges Inherited | boolean | undefined | GraphicBuilderOptions | Controls whether edges are generated for surfaces. |
pickable Inherited | PickableGraphicOptions | undefined | GraphicBuilderOptions | If the graphic is to be pickable, specifies the pickable Id and other options. |
placement Inherited | Transform | undefined | GraphicBuilderOptions | The local-to-world transform in which the builder's geometry is to be defined - by default, an identity transform. |
preserveOrder Inherited | boolean | undefined | GraphicBuilderOptions | If true, the order in which geometry is added to the builder is preserved. |
type Inherited | GraphicType | GraphicBuilderOptions | The type of graphic to produce. |
viewIndependentOrigin Inherited | Point3d | undefined | GraphicBuilderOptions | If defined, specifies a point about which the graphic will rotate such that it always faces the viewer. |
wantNormals Inherited | boolean | undefined | GraphicBuilderOptions | Controls whether normals are generated for surfaces. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.