PickableGraphicOptions Interface
Options used as part of GraphicBuilderOptions to describe a pickable RenderGraphic.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
geometryClass | GeometryClass | undefined | Optional geometry class for the graphic - defaults to GeometryClass.Primary. | |
id | string | A unique identifier for the graphic. | |
isVolumeClassifier | boolean | undefined | True if the graphic is to be used as a DynamicSpatialClassifier to classify volumes of a reality model. | |
modelId | string | undefined | The optional Id of the model with which the graphic should be associated. | |
subCategoryId | string | undefined | Optional Id of the subcategory with which the graphic should be associated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
locateOnly Inherited | boolean | undefined | BatchOptions | If true, the contents of the batch will only be drawn by readPixels, not renderFrame, causing them to be locatable but invisible. |
noEmphasis Inherited | boolean | undefined | BatchOptions | If true, features within the batch will not be emphasized when the corresponding Feature is emphasized using FeatureOverrides. |
noFlash Inherited | boolean | undefined | BatchOptions | If true, features within the batch will not be flashed on mouseover. |
noHilite Inherited | boolean | undefined | BatchOptions | If true, features within the batch will not be hilited when their corresponding element is in the SelectionSet. |
tileId Inherited | string | undefined | BatchOptions | Identifies the Tile associated with the batch, chiefly for debugging purposes. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.