ComputeChordToleranceArgs Interface
Arguments used to compute the chord tolerance (level of detail) of the RenderGraphic or GraphicTemplate produced by a GraphicBuilder. Generally, the chord tolerance should be roughly equivalent to the size in meters of one pixel on screen where the graphic is to be displayed. For ViewOverlay and ViewBackground, which already define their geometry in pixels, the chord tolerance should typically be 1.
@see computeChordTolerance.
Properties
Name | Type | Description | |
---|---|---|---|
computeRange Readonly | () => Range3d | A function that computes a range enclosing all of the geometry that was added to the builder. | |
graphic Readonly | GraphicBuilder | The graphic builder being used to produce the graphics. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.