SnapshotConnection Class

A connection to a SnapshotDb hosted on a backend.

Extends

Methods

Name Description
close(): Promise<void> Close this SnapshotConnection.  
isSnapshotConnection(): this is SnapshotConnection Type guard for instanceof SnapshotConnection  
openFile(filePath: string): Promise<SnapshotConnection> Static Open an IModelConnection to a read-only snapshot iModel from a file name.  
openRemote(fileKey: string): Promise<SnapshotConnection> Static Open an IModelConnection to a remote read-only snapshot iModel from a key that will be resolved by the backend. Deprecated  

Inherited methods

Name Inherited from Description
cartographicFromSpatial(spatial: Readonly<WritableXYAndZ>[]): Promise<Cartographic[]> Inherited IModelConnection Convert points in this iModel's spatial coordinate system to Cartographic coordinates using either a GeoConverter or the iModel's EcefLocation.
cartographicToSpatial(cartographic: Cartographic, result?: Point3d): Promise<Point3d> Inherited IModelConnection Convert a Cartographic to a point in this iModel's Spatial coordinates using a GeoConverter or[IModel.ecefLocation.
cartographicToSpatialFromEcef(cartographic: Cartographic, result?: Point3d): Point3d Inherited IModelConnection Convert a Cartographic to a point in this iModel's Spatial coordinates using its IModel.ecefLocation.
cartographicToSpatialFromGcs(cartographic: Cartographic, result?: Point3d): Promise<Point3d> Inherited IModelConnection Convert a Cartographic to a point in this iModel's spatial coordinate system using a GeoConverter.
createQueryReader(ecsql: string, params?: QueryBinder, config?: QueryOptions): ECSqlReader Inherited IModelConnection Allow to execute query and read results along with meta data.
ecefToSpatial(ecef: Readonly<WritableXYAndZ>, result?: Point3d): Point3d Inherited IModelConnection Convert a point in ECEF coordinates to a point in this iModel's Spatial coordinates using its ecefLocation.
expandDisplayedExtents(range: Range3d): void Inherited IModelConnection Expand this iModel's displayedExtents to include the specified range.
findClassFor<T extends >(className: string, defaultClass: T): Promise<undefined | T> Inherited IModelConnection Find the first registered base class of the given EntityState className.
generateElementMeshes(requestProps: ElementMeshRequestProps): Promise<Uint8Array> Inherited IModelConnection Produce encoded Polyfaces from the geometry stream of a GeometricElement.
getEcefTransform(): Transform Inherited IModelConnection Get the Transform from this iModel's Spatial coordinates to ECEF coordinates using its IModel.ecefLocation.
getGeometryContainment(requestProps: GeometryContainmentRequestProps): Promise<GeometryContainmentResponseProps> Inherited IModelConnection Request element clip containment status from the backend.
getGeometrySummary(requestProps: GeometrySummaryRequestProps): Promise<string> Inherited IModelConnection Obtain a summary of the geometry belonging to one or more GeometricElements suitable for debugging and diagnostics.
getMassProperties(requestProps: MassPropertiesRequestProps): Promise<MassPropertiesResponseProps> Inherited IModelConnection Request element mass properties from the backend.
getMassPropertiesPerCandidate(requestProps: MassPropertiesPerCandidateRequestProps): Promise<MassPropertiesPerCandidateResponseProps[]> Inherited IModelConnection Request mass properties for multiple elements from the backend.
getRpcProps(): IModelRpcProps Inherited IModelConnection Return a token for RPC operations.
getToolTipMessage(id: string): Promise<string[]> Inherited IModelConnection Request a tooltip from the backend.
isBlankConnection(): this is BlankConnection Inherited IModelConnection Type guard for instanceof BlankConnection
isBriefcaseConnection(): this is BriefcaseConnection Inherited IModelConnection Type guard for instanceof BriefcaseConnection
isCheckpointConnection(): this is CheckpointConnection Inherited IModelConnection Type guard for instanceof CheckpointConnection
loadFontMap(): Promise<FontMap> Inherited IModelConnection Load the FontMap for this IModelConnection.
query(ecsql: string, params?: QueryBinder, options?: QueryOptions): AsyncIterableIterator<any, any, any> Inherited IModelConnection Execute a query and stream its results
queryEntityIds(params: EntityQueryParams): Promise<Id64Set> Inherited IModelConnection Query for a set of element ids that satisfy the supplied query params
queryRowCount(ecsql: string, params?: QueryBinder): Promise<number> Inherited IModelConnection Compute number of rows that would be returned by the ECSQL.
queryTextureData(textureLoadProps: TextureLoadProps): Promise<undefined | TextureData> Inherited IModelConnection Request a named texture image from the backend.
restartQuery(token: string, ecsql: string, params?: QueryBinder, options?: QueryOptions): AsyncIterableIterator<any, any, any> Inherited IModelConnection Cancel any previous query with same token and run execute the current specified query.
setEcefLocation(ecef: EcefLocationProps): void Inherited IModelConnection Set the EcefLocation for this iModel.
setGeographicCoordinateSystem(geoCRS: GeographicCRSProps): void Inherited IModelConnection Sets the geographic coordinate reference system from GeographicCRSProps.
spatialFromCartographic(cartographic: Cartographic[]): Promise<Point3d[]> Inherited IModelConnection Convert Cartographic coordinates into points in this iModel's spatial coordinate system using a GeoConverter or the iModel's EcefLocation.
spatialToCartographic(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Promise<Cartographic> Inherited IModelConnection Convert a point in this iModel's Spatial coordinates to a Cartographic using the Geographic location services for this IModelConnection or IModel.ecefLocation.
spatialToCartographicFromEcef(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Cartographic Inherited IModelConnection Convert a point in this iModel's Spatial coordinates to a Cartographic using its IModel.ecefLocation.
spatialToCartographicFromGcs(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Promise<Cartographic> Inherited IModelConnection Convert a point in this iModel's Spatial coordinates to a Cartographic using the Geographic location services for this IModelConnection.
spatialToEcef(spatial: Readonly<WritableXYAndZ>, result?: Point3d): Point3d Inherited IModelConnection Convert a point in this iModel's Spatial coordinates to an ECEF point using its IModel.ecefLocation.
toJSON(): IModelConnectionProps Inherited IModelConnection Convert this iModel to a JSON representation.
toSpatialFromGcs(geoCoords: Readonly<WritableXYAndZ>[], datumOrGCRS?: string | GeographicCRSProps): Promise<Point3d[]> Inherited IModelConnection Convert geographic coordinates into points in this iModel's spatial coordinate system using a GeoConverter or the iModel's EcefLocation.
wgs84CartographicFromSpatial(spatial: Readonly<WritableXYAndZ>[]): Promise<Cartographic[]> Inherited IModelConnection Convert points in this iModel's spatial coordinate system to Cartographic coordinates using either a GeoConverter or the iModel's EcefLocation.
getDefaultSubCategoryId(categoryId: string): string Static Inherited IModelConnection Get the default subCategoryId for the supplied categoryId

Properties

Name Type Description
iModelId Accessor ReadOnly string The Guid that identifies this iModel.  
isClosed Accessor ReadOnly boolean Returns true if close has already been called.  
isRemote Accessor ReadOnly boolean Returns true if this is a connection to a remote snapshot iModel resolved by the backend.  

Inherited properties

Name Type Inherited from Description
_openMode Protected Inherited OpenMode IModelConnection  
categories Readonly Inherited IModelConnection.Categories IModelConnection The set of Category's in this IModelConnection.
changeset Accessor Inherited ChangesetIdWithIndex IModelConnection  
codeSpecs Readonly Inherited IModelConnection.CodeSpecs IModelConnection The CodeSpecs in this IModelConnection.
connectionTimeout Static Inherited number IModelConnection The maximum time (in milliseconds) to wait before timing out the request to open a connection to a new iModel
dictionaryId Static Readonly Inherited string IModelConnection The Id of the dictionary model.
displayedExtents Readonly Inherited Range3d IModelConnection The displayed extents of this iModel, initialized to IModel.projectExtents.
ecefLocation Accessor Inherited undefined | EcefLocation IModelConnection The EcefLocation of the iModel in Earth Centered Earth Fixed coordinates.
If the iModel property geographicCoordinateSystem is not defined then the ecefLocation provides a geolocation by defining a
3D coordinate system relative to the Earth model WGS84. Refer to additional documentation for details. If the geographicCoordinateSystem
property is defined then the ecefLocation must be used with care. When the geographicCoordinateSystem is defined it indicates the
iModel cartesian space is the result of a cartographic projection. This implies a flattening of the Earth surface process that
results in scale, angular or area distortion. The ecefLocation is then an approximation calculated at the center of the project extent.
If the project is more than 2 kilometer in size, the ecefLocation may represent a poor approximation of the effective
cartographic projection used and a linear transformation should then be calculated at the exact origin of the data
it must position.
elements Readonly Inherited IModelConnection.Elements IModelConnection The ElementStates in this IModelConnection.
fontMap Inherited FontMap | undefined IModelConnection The font map for this IModelConnection.
geographicCoordinateSystem Accessor Inherited undefined | GeographicCRS IModelConnection The geographic coordinate reference system of the iModel.
geoServices Readonly Inherited GeoServices IModelConnection The Geographic location services available for this iModelConnection.
globalOrigin Accessor Inherited Point3d IModelConnection An offset to be applied to all spatial coordinates.
hilited Readonly Inherited HiliteSet IModelConnection The set of currently hilited elements for this IModelConnection.
isBlank Accessor Inherited ReadOnly boolean IModelConnection True if this is a Blank Connection.
isBriefcase Accessor Inherited ReadOnly boolean IModelConnection Returns true if this is a briefcase copy of an iModel that is synchronized with iModelHub.
isGeoLocated Accessor Inherited ReadOnly boolean IModelConnection True if this iModel has an EcefLocation.
isOpen Accessor Inherited ReadOnly boolean IModelConnection Check if the IModelConnection is open (i.e. it has a connection to a backend server).
Returns false for BlankConnection instances and after IModelConnection.close has been called.
isReadonly Accessor Inherited ReadOnly boolean IModelConnection Check the openMode of this IModelConnection to see if it was opened read-only.
isSnapshot Accessor Inherited ReadOnly boolean IModelConnection Returns true if this is a snapshot iModel.
iTwinId Accessor Inherited ReadOnly undefined | string IModelConnection The Guid that identifies the iTwin that owns this iModel.
key Accessor Inherited ReadOnly string IModelConnection Get the key that was used to open this iModel. This is the value used for Rpc and Ipc communications.
models Readonly Inherited IModelConnection.Models IModelConnection The ModelStates in this IModelConnection.
name Accessor Inherited string IModelConnection Name of the iModel
onChangesetChanged Readonly Inherited BeEvent<(previousChangeset: ChangesetIdWithIndex) => void> IModelConnection Event raised after changeset changes.
onClose Readonly Inherited BeEvent<(_imodel: IModelConnection) => void> IModelConnection Event raised immediately before this IModelConnection is closed.
onClose Static Readonly Inherited BeEvent<(_imodel: IModelConnection) => void> IModelConnection Event raised immediately before any IModelConnection is closed.
onEcefLocationChanged Readonly Inherited BeEvent<(previousLocation: EcefLocation) => void> IModelConnection Event raised after ecefLocation changes.
onGeographicCoordinateSystemChanged Readonly Inherited BeEvent<(previousGCS: GeographicCRS) => void> IModelConnection Event raised after geographicCoordinateSystem changes.
onGlobalOriginChanged Readonly Inherited BeEvent<(previousOrigin: Point3d) => void> IModelConnection Event raised after globalOrigin changes.
onNameChanged Readonly Inherited BeEvent<(previousName: string) => void> IModelConnection Event raised after name changes.
onOpen Static Readonly Inherited BeEvent<(_imodel: IModelConnection) => void> IModelConnection Event called immediately after any IModelConnection is opened.
onProjectExtentsChanged Readonly Inherited BeEvent<(previousExtents: Range3d) => void> IModelConnection Event raised after projectExtents changes.
onRootSubjectChanged Readonly Inherited BeEvent<(previousSubject: RootSubjectProps) => void> IModelConnection Event raised after rootSubject changes.
openMode Accessor Inherited ReadOnly OpenMode IModelConnection The OpenMode used for this IModel.
projectExtents Accessor Inherited Range3d IModelConnection The volume, in spatial coordinates, inside which the entire project is contained.
repositoryModelId Static Readonly Inherited string IModelConnection The Id of the repository model.
rootSubject Accessor Inherited RootSubjectProps IModelConnection The name and description of the root subject of this iModel
rootSubjectId Static Readonly Inherited string IModelConnection The Id of the root subject element.
routingContext Inherited IModelRoutingContext IModelConnection The RPC routing for this connection.
selectionSet Readonly Inherited SelectionSet IModelConnection The set of currently selected elements for this IModelConnection.
tiles Readonly Inherited Tiles IModelConnection The set of Tiles for this IModelConnection.
transientIds Readonly Inherited TransientIdSequence IModelConnection Generator for unique Ids of transient graphics for this IModelConnection.
views Readonly Inherited IModelConnection.Views IModelConnection The ViewStates in this IModelConnection.

Defined in

Last Updated: 21 November, 2024