MassPropertiesPerCandidateResponseProps Interface

Information returned from the back end to the front end holding the result of the mass properties calculation for a single candidate.

Extends

Properties

Name Type Description
candidate string    

Inherited properties

Name Type Inherited from Description
area Inherited number | undefined MassPropertiesResponseProps Surface area of solids and surfaces when AccumulateVolumes or AccumulateAreas requested
centroid Inherited XYZProps | undefined MassPropertiesResponseProps Centroid of geometry
ixy Inherited number | undefined MassPropertiesResponseProps Product of inertia with respect to xy plane
ixz Inherited number | undefined MassPropertiesResponseProps Product of inertia with respect to xz plane
iyz Inherited number | undefined MassPropertiesResponseProps Product of inertia with respect to yz plane
length Inherited number | undefined MassPropertiesResponseProps Length of curves or perimeter of planar regions when AccumulateAreas or AccumulateLength requested
moments Inherited XYZProps | undefined MassPropertiesResponseProps Moments of inertia
perimeter Inherited number | undefined MassPropertiesResponseProps Perimeter of surfaces and planar regions when AccumulateAreas requested
status Inherited BentleyStatus MassPropertiesResponseProps Success if requested MassPropertiesOperation could be evaluated for the specified elements
volume Inherited number | undefined MassPropertiesResponseProps Volume of solids when AccumulateVolumes requested

Defined in

Last Updated: 21 November, 2024