CatalogConnection Namespace

Function

Name Description
CatalogConnection.acquireWriteLock Acquire the write lock for a CatalogIModel container.
CatalogConnection.createNewContainer Create a new BlobContainer to hold versions of a CatalogIModel.
CatalogConnection.createNewVersion Create a new version of a CatalogIModel as a copy of an existing version.
CatalogConnection.openEditable Open a CatalogIModel for write access.
CatalogConnection.openReadonly Open a CatalogIModel for read access.
CatalogConnection.releaseWriteLock Release the write lock on a CatalogIModel container.

Defined in

CatalogConnection Interface

A read-only connection to a CatalogDb.

@note CatalogConnection may only be used in NativeApps

@see openReadonly to instantiate this type.

Extends

Methods

Name Description
getCatalogInfo(): Promise<{ manifest?: CatalogIModel.Manifest, version: string }>    
isEditable(): this is EditableCatalogConnection    

Inherited methods

Name Inherited from Description
abandonChanges(): Promise<void> Inherited BriefcaseConnection Abandon pending changes to this briefcase.
cartographicFromSpatial(spatial: Readonly<WritableXYAndZ>[]): Promise<Cartographic[]> Inherited BriefcaseConnection Convert points in this iModel's spatial coordinate system to Cartographic coordinates using either a GeoConverter or the iModel's EcefLocation.
cartographicToSpatial(cartographic: Cartographic, result?: Point3d): Promise<Point3d> Inherited BriefcaseConnection Convert a Cartographic to a point in this iModel's Spatial coordinates using a GeoConverter or[IModel.ecefLocation.
cartographicToSpatialFromEcef(cartographic: Cartographic, result?: Point3d): Point3d Inherited BriefcaseConnection Convert a Cartographic to a point in this iModel's Spatial coordinates using its IModel.ecefLocation.
cartographicToSpatialFromGcs(cartographic: Cartographic, result?: Point3d): Promise<Point3d> Inherited BriefcaseConnection Convert a Cartographic to a point in this iModel's spatial coordinate system using a GeoConverter.
close(): Promise<void> Inherited BriefcaseConnection Close this BriefcaseConnection.
createQueryReader(ecsql: string, params?: QueryBinder, config?: QueryOptions): ECSqlReader Inherited BriefcaseConnection Allow to execute query and read results along with meta data.
ecefToSpatial(ecef: Readonly<WritableXYAndZ>, result?: Point3d): Point3d Inherited BriefcaseConnection Convert a point in ECEF coordinates to a point in this iModel's Spatial coordinates using its ecefLocation.
enterEditingScope(): Promise<GraphicalEditingScope> Inherited BriefcaseConnection Begin a new graphical editing scope.
findClassFor<T extends >(className: string, defaultClass: T): Promise<undefined | T> Inherited BriefcaseConnection Find the first registered base class of the given EntityState className.
generateElementMeshes(requestProps: ElementMeshRequestProps): Promise<Uint8Array> Inherited BriefcaseConnection Produce encoded Polyfaces from the geometry stream of a GeometricElement.
getEcefTransform(): Transform Inherited BriefcaseConnection Get the Transform from this iModel's Spatial coordinates to ECEF coordinates using its IModel.ecefLocation.
getGeometryContainment(requestProps: GeometryContainmentRequestProps): Promise<GeometryContainmentResponseProps> Inherited BriefcaseConnection Request element clip containment status from the backend.
getGeometrySummary(requestProps: GeometrySummaryRequestProps): Promise<string> Inherited BriefcaseConnection Obtain a summary of the geometry belonging to one or more GeometricElements suitable for debugging and diagnostics.
getMassProperties(requestProps: MassPropertiesRequestProps): Promise<MassPropertiesResponseProps> Inherited BriefcaseConnection Request element mass properties from the backend.
getMassPropertiesPerCandidate(requestProps: MassPropertiesPerCandidateRequestProps): Promise<MassPropertiesPerCandidateResponseProps[]> Inherited BriefcaseConnection Request mass properties for multiple elements from the backend.
getRpcProps(): IModelRpcProps Inherited BriefcaseConnection Return a token for RPC operations.
getToolTipMessage(id: string): Promise<string[]> Inherited BriefcaseConnection Request a tooltip from the backend.
hasPendingTxns(): Promise<boolean> Inherited BriefcaseConnection Query if there are any pending Txns in this briefcase that are waiting to be pushed.
isBlankConnection(): this is BlankConnection Inherited BriefcaseConnection Type guard for instanceof BlankConnection
isBriefcaseConnection(): this is BriefcaseConnection Inherited BriefcaseConnection Type guard for instanceof BriefcaseConnection
isCheckpointConnection(): this is CheckpointConnection Inherited BriefcaseConnection Type guard for instanceof CheckpointConnection
isSnapshotConnection(): this is SnapshotConnection Inherited BriefcaseConnection Type guard for instanceof SnapshotConnection
loadFontMap(): Promise<FontMap> Inherited BriefcaseConnection Load the FontMap for this IModelConnection.
pullChanges(toIndex?: number, options?: PullChangesOptions): Promise<void> Inherited BriefcaseConnection Pull (and potentially merge if there are local changes) up to a specified changeset from iModelHub into this briefcase
pushChanges(description: string): Promise<ChangesetIndexAndId> Inherited BriefcaseConnection Create a changeset from local Txns and push to iModelHub.
queryEntityIds(params: EntityQueryParams): Promise<Id64Set> Inherited BriefcaseConnection Query for a set of element ids that satisfy the supplied query params
queryTextureData(textureLoadProps: TextureLoadProps): Promise<undefined | TextureData> Inherited BriefcaseConnection Request a named texture image from the backend.
requireTimeline(): void Protected Inherited BriefcaseConnection  
saveChanges(description?: string): Promise<void> Inherited BriefcaseConnection Commit pending changes to this briefcase.
setEcefLocation(ecef: EcefLocationProps): void Inherited BriefcaseConnection Set the EcefLocation for this iModel.
setGeographicCoordinateSystem(geoCRS: GeographicCRSProps): void Inherited BriefcaseConnection Sets the geographic coordinate reference system from GeographicCRSProps.
spatialFromCartographic(cartographic: Cartographic[]): Promise<Point3d[]> Inherited BriefcaseConnection Convert Cartographic coordinates into points in this iModel's spatial coordinate system using a GeoConverter or the iModel's EcefLocation.
spatialToCartographic(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Promise<Cartographic> Inherited BriefcaseConnection Convert a point in this iModel's Spatial coordinates to a Cartographic using the Geographic location services for this IModelConnection or IModel.ecefLocation.
spatialToCartographicFromEcef(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Cartographic Inherited BriefcaseConnection Convert a point in this iModel's Spatial coordinates to a Cartographic using its IModel.ecefLocation.
spatialToCartographicFromGcs(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Promise<Cartographic> Inherited BriefcaseConnection Convert a point in this iModel's Spatial coordinates to a Cartographic using the Geographic location services for this IModelConnection.
spatialToEcef(spatial: Readonly<WritableXYAndZ>, result?: Point3d): Point3d Inherited BriefcaseConnection Convert a point in this iModel's Spatial coordinates to an ECEF point using its IModel.ecefLocation.
supportsGraphicalEditing(): Promise<boolean> Inherited BriefcaseConnection Return whether graphical editing is supported for this briefcase.
toJSON(): IModelConnectionProps Inherited BriefcaseConnection Convert this iModel to a JSON representation.
toSpatialFromGcs(geoCoords: Readonly<WritableXYAndZ>[], datumOrGCRS?: string | GeographicCRSProps): Promise<Point3d[]> Inherited BriefcaseConnection Convert geographic coordinates into points in this iModel's spatial coordinate system using a GeoConverter or the iModel's EcefLocation.
wgs84CartographicFromSpatial(spatial: Readonly<WritableXYAndZ>[]): Promise<Cartographic[]> Inherited BriefcaseConnection Convert points in this iModel's spatial coordinate system to Cartographic coordinates using either a GeoConverter or the iModel's EcefLocation.

Inherited properties

Name Type Inherited from Description
_isClosed Protected Inherited boolean | undefined BriefcaseConnection  
_openMode Protected Inherited OpenMode BriefcaseConnection  
categories Readonly Inherited IModelConnection.Categories BriefcaseConnection The set of Category's in this IModelConnection.
codeSpecs Readonly Inherited IModelConnection.CodeSpecs BriefcaseConnection The CodeSpecs in this IModelConnection.
editorToolSettings Readonly Inherited BriefcaseEditorToolSettings BriefcaseConnection Default settings that can be used to control the behavior of Tools that modify this briefcase.
elements Readonly Inherited IModelConnection.Elements BriefcaseConnection The ElementStates in this IModelConnection.
fontMap Inherited FontMap | undefined BriefcaseConnection The font map for this IModelConnection.
geoServices Readonly Inherited GeoServices BriefcaseConnection The Geographic location services available for this iModelConnection.
hilited Readonly Inherited HiliteSet BriefcaseConnection The set of currently hilited elements for this IModelConnection.
models Readonly Inherited IModelConnection.Models BriefcaseConnection The ModelStates in this IModelConnection.
onChangesetChanged Readonly Inherited BeEvent<(previousChangeset: ChangesetIdWithIndex) => void> BriefcaseConnection Event raised after changeset changes.
onClose Readonly Inherited BeEvent<(_imodel: IModelConnection) => void> BriefcaseConnection Event raised immediately before this IModelConnection is closed.
onEcefLocationChanged Readonly Inherited BeEvent<(previousLocation: EcefLocation) => void> BriefcaseConnection Event raised after ecefLocation changes.
onGeographicCoordinateSystemChanged Readonly Inherited BeEvent<(previousGCS: GeographicCRS) => void> BriefcaseConnection Event raised after geographicCoordinateSystem changes.
onGlobalOriginChanged Readonly Inherited BeEvent<(previousOrigin: Point3d) => void> BriefcaseConnection Event raised after globalOrigin changes.
onNameChanged Readonly Inherited BeEvent<(previousName: string) => void> BriefcaseConnection Event raised after name changes.
onProjectExtentsChanged Readonly Inherited BeEvent<(previousExtents: Range3d) => void> BriefcaseConnection Event raised after projectExtents changes.
onRootSubjectChanged Readonly Inherited BeEvent<(previousSubject: RootSubjectProps) => void> BriefcaseConnection Event raised after rootSubject changes.
routingContext Inherited IModelRoutingContext BriefcaseConnection The RPC routing for this connection.
selectionSet Readonly Inherited SelectionSet BriefcaseConnection The set of currently selected elements for this IModelConnection.
tiles Readonly Inherited Tiles BriefcaseConnection The set of Tiles for this IModelConnection.
transientIds Readonly Inherited TransientIdSequence BriefcaseConnection Generator for unique Ids of transient graphics for this IModelConnection.
txns Readonly Inherited BriefcaseTxns BriefcaseConnection Manages local changes to the briefcase via Txns.
views Readonly Inherited IModelConnection.Views BriefcaseConnection The ViewStates in this IModelConnection.
changeset Accessor Inherited ChangesetIdWithIndex BriefcaseConnection  
ecefLocation Accessor Inherited undefined | EcefLocation BriefcaseConnection The EcefLocation of the iModel in Earth Centered Earth Fixed coordinates.
If the iModel property geographicCoordinateSystem is not defined then the ecefLocation provides a geolocation by defining a
3D coordinate system relative to the Earth model WGS84. Refer to additional documentation for details. If the geographicCoordinateSystem
property is defined then the ecefLocation must be used with care. When the geographicCoordinateSystem is defined it indicates the
iModel cartesian space is the result of a cartographic projection. This implies a flattening of the Earth surface process that
results in scale, angular or area distortion. The ecefLocation is then an approximation calculated at the center of the project extent.
If the project is more than 2 kilometer in size, the ecefLocation may represent a poor approximation of the effective
cartographic projection used and a linear transformation should then be calculated at the exact origin of the data
it must position.
editingScope Accessor Inherited ReadOnly undefined | GraphicalEditingScope BriefcaseConnection The current graphical editing scope, if one is in progress.
geographicCoordinateSystem Accessor Inherited undefined | GeographicCRS BriefcaseConnection The geographic coordinate reference system of the iModel.
globalOrigin Accessor Inherited Point3d BriefcaseConnection An offset to be applied to all spatial coordinates.
iModelId Accessor Inherited ReadOnly string BriefcaseConnection The Guid that identifies this iModel.
isBlank Accessor Inherited ReadOnly boolean BriefcaseConnection True if this is a Blank Connection.
isBriefcase Accessor Inherited ReadOnly boolean BriefcaseConnection Returns true if this is a briefcase copy of an iModel that is synchronized with iModelHub.
isClosed Accessor Inherited ReadOnly boolean BriefcaseConnection Returns true if close has already been called.
isGeoLocated Accessor Inherited ReadOnly boolean BriefcaseConnection True if this iModel has an EcefLocation.
isOpen Accessor Inherited ReadOnly boolean BriefcaseConnection Check if the IModelConnection is open (i.e. it has a connection to a backend server).
Returns false for BlankConnection instances and after IModelConnection.close has been called.
isReadonly Accessor Inherited ReadOnly boolean BriefcaseConnection Check the openMode of this IModelConnection to see if it was opened read-only.
isSnapshot Accessor Inherited ReadOnly boolean BriefcaseConnection Returns true if this is a snapshot iModel.
iTwinId Accessor Inherited ReadOnly string BriefcaseConnection The Guid that identifies the iTwin that owns this iModel.
key Accessor Inherited ReadOnly string BriefcaseConnection Get the key that was used to open this iModel. This is the value used for Rpc and Ipc communications.
name Accessor Inherited string BriefcaseConnection Name of the iModel
openMode Accessor Inherited ReadOnly OpenMode BriefcaseConnection The OpenMode used for this IModel.
projectExtents Accessor Inherited Range3d BriefcaseConnection The volume, in spatial coordinates, inside which the entire project is contained.
rootSubject Accessor Inherited RootSubjectProps BriefcaseConnection The name and description of the root subject of this iModel
schemaContext Accessor Inherited ReadOnly SchemaContext BriefcaseConnection Gets the context that allows accessing the metadata (see @itwin/ecschema-metadata package) of this iModel.
The context is created lazily when this property is accessed for the first time, with an ECSchemaRpcLocater registered as a fallback locater, enabling users to register their own locater that'd take more priority.
This means to correctly access schema context, client-side applications must register ECSchemaRpcInterface following instructions for RPC configuration.
Server-side applications would also configure RPC as needed.

Defined in

Last Updated: 26 April, 2025