PresentationManager Class
Frontend Presentation manager which basically just forwards all calls to the backend implementation.
Implements
Methods
Name | Description | |
---|---|---|
dispose(): void | Disposes of any resources owned by this object. | |
getContent(requestOptions: ContentRequestOptions<IModelConnection, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<undefined | Content> | Retrieves content which consists of a content descriptor and a page of records. | Deprecated |
getContentAndSize(requestOptions: ContentRequestOptions<IModelConnection, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<undefined | { content: Content, size: number }> | Retrieves content set size and content which consists of a content descriptor and a page of records. | Deprecated |
getContentDescriptor(requestOptions: ContentDescriptorRequestOptions<IModelConnection, KeySet, RulesetVariable> & ClientDiagnosticsAttribute): Promise<undefined | Descriptor> | Retrieves the content descriptor which describes the content and can be used to customize it. | |
getContentInstanceKeys(requestOptions: ContentInstanceKeysRequestOptions<IModelConnection, KeySet, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<{ items: () => AsyncGenerator<InstanceKey, any, any>, total: number }> | Retrieves content item instance keys. | |
getContentIterator(requestOptions: ContentRequestOptions<IModelConnection, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<undefined | { descriptor: Descriptor, items: AsyncIterableIterator<Item, any, any>, total: number }> | Retrieves a content descriptor, item count and async generator for the items themselves. | |
getContentSetSize(requestOptions: GetContentRequestOptions): Promise<number> | Retrieves overall content set size. | |
getContentSources(requestOptions: ContentSourcesRequestOptions<IModelConnection> & ClientDiagnosticsAttribute): Promise<SelectClassInfo[]> | Get information about the sources of content when building it for specific ECClasses. | |
getDisplayLabelDefinition(requestOptions: DisplayLabelRequestOptions<IModelConnection, InstanceKey> & ClientDiagnosticsAttribute): Promise<LabelDefinition> | Retrieves display label definition of specific item. | |
getDisplayLabelDefinitions(requestOptions: DisplayLabelsRequestOptions<IModelConnection, InstanceKey> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<LabelDefinition[]> | Retrieves display label definition of specific items. | Deprecated |
getDisplayLabelDefinitionsIterator(requestOptions: DisplayLabelsRequestOptions<IModelConnection, InstanceKey> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<{ items: AsyncIterableIterator<LabelDefinition, any, any>, total: number }> | Retrieves display label definition of specific items. | |
getDistinctValuesIterator(requestOptions: DistinctValuesRequestOptions<IModelConnection, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<{ items: AsyncIterableIterator<DisplayValueGroup, any, any>, total: number }> | Returns an iterator that asynchronously polls distinct values of specific field from the content. | |
getElementProperties<TParsedContent>(requestOptions: SingleElementPropertiesRequestOptions<IModelConnection, TParsedContent> & ClientDiagnosticsAttribute): Promise<undefined | TParsedContent> | Retrieves property data in a simplified format for a single element specified by ID. | |
getFilteredNodePaths(requestOptions: FilterByTextHierarchyRequestOptions<IModelConnection, RulesetVariable> & ClientDiagnosticsAttribute): Promise<NodePathElement[]> | Retrieves paths from root nodes to nodes containing filter text in their label. | |
getNodePaths(requestOptions: FilterByInstancePathsHierarchyRequestOptions<IModelConnection, RulesetVariable> & ClientDiagnosticsAttribute): Promise<NodePathElement[]> | Retrieves paths from root nodes to children nodes according to specified keys. | |
getNodes(requestOptions: HierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<Node[]> | Retrieves nodes | Deprecated |
getNodesAndCount(requestOptions: HierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<{ count: number, nodes: Node[] }> | Retrieves total nodes count and a single page of nodes. | Deprecated |
getNodesCount(requestOptions: GetNodesRequestOptions): Promise<number> | Retrieves nodes count. | |
getNodesDescriptor(requestOptions: HierarchyLevelDescriptorRequestOptions<IModelConnection, NodeKey, RulesetVariable> & ClientDiagnosticsAttribute): Promise<undefined | Descriptor> | Retrieves hierarchy level descriptor. | |
getNodesIterator(requestOptions: HierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<{ items: AsyncIterableIterator<Node, any, any>, total: number }> | Returns an iterator that polls nodes asynchronously. | |
getPagedDistinctValues(requestOptions: DistinctValuesRequestOptions<IModelConnection, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<PagedResponse<DisplayValueGroup>> | Retrieves distinct values of specific field from the content. | Deprecated |
rulesets(): RulesetManager | Get rulesets manager | |
vars(rulesetId: string): RulesetVariablesManager | Get ruleset variables manager for specific ruleset | |
create(props?: PresentationManagerProps): PresentationManager Static | Create a new PresentationManager instance |
Properties
Name | Type | Description | |
---|---|---|---|
activeLocale Accessor | undefined | string | Get / set active locale used for localizing presentation data | |
activeUnitSystem Accessor | UnitSystemKey | Get / set active unit system used to format property values with units. | |
onIModelContentChanged | BeEvent<(args: IModelContentChangeEventArgs) => void> | An event raised when content created using specific ruleset changes | |
onIModelHierarchyChanged | BeEvent<(args: IModelHierarchyChangeEventArgs) => void> | An event raised when hierarchies created using specific ruleset change |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.