Node Interface
Data structure that describes a tree node.
Properties
Name | Type | Description | |
---|---|---|---|
description | string | undefined | Extensive description | |
extendedData | [key: string]: any | undefined | Extended data injected into this node | |
hasChildren | boolean | undefined | Does this node have child nodes | |
imageId | string | undefined | Image ID | Deprecated |
isEditable | boolean | undefined | Is this node editable | |
isExpanded | boolean | undefined | Is this node expanded | |
isSelectionDisabled | boolean | undefined | Is this node selectable | |
key | NodeKey | A key that uniquely identifies a node. | |
label | LabelDefinition | Definition of node display label | |
supportsFiltering | boolean | undefined | Identifies whether the hierarchy level below this node supports filtering. |
Defined in
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.