PresentationError Class
An error type thrown by Presentation APIs.
Extends
Methods
Name | Description | |
---|---|---|
constructor(errorNumber: PresentationStatus, message?: string, getMetaData?: GetMetaDataFunction): PresentationError | Creates an instance of Error. | |
_initName(): string Protected | Returns the name of each error status. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getMetaData(): undefined | object Inherited | BentleyError | get the meta data associated with this BentleyError, if any. |
getErrorKey(errorNumber: number): string Static Inherited | BentleyError | This function returns the name of each error status. |
BentleyError | Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists. |
|
getErrorMetadata(error: unknown): undefined | object Static Inherited | BentleyError | Use run-time type checking to safely get the metadata with an unknown error value, if possible. |
getErrorProps(error: unknown): ErrorProps Static Inherited | BentleyError | Returns a new ErrorProps object representing an unknown error value. |
getErrorStack(error: unknown): undefined | string Static Inherited | BentleyError | Use run-time type checking to safely get the call stack of an unknown error value, if possible. |
getMetaData(metaData: LoggingMetaData): undefined | object Static Inherited | BentleyError | get the metadata object associated with an ExceptionMetaData, if any. |
isError<T extends LegacyITwinErrorWithNumber>(error: unknown, errorNumber?: number): error is T Static Inherited | BentleyError | Determine if an error object implements the LegacyITwinErrorWithNumber interface. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
errorNumber Inherited | number | BentleyError | |
hasMetaData Accessor Inherited ReadOnly | boolean | BentleyError | Returns true if this BentleyError includes (optional) metadata. |
iTwinErrorId Accessor Inherited ReadOnly | { key: string, scope: string } | BentleyError | supply the value for iTwinErrorId |
iTwinErrorScope Static Readonly Inherited | "bentley-error" | BentleyError | |
loggingMetadata Accessor Inherited ReadOnly | undefined | object | BentleyError | value for logging metadata |
Defined in
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.