LinearlyReferencedLocation Class
Base class for multi-aspects carrying linearly-referenced locations.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(props: ElementAspectProps, iModel: IModelDb): LinearlyReferencedLocation | Construct an aspect from its JSON representation and its containing iModel. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(_referenceIds: EntityReferenceSet): void Protected Inherited | ElementMultiAspect | Collect the Ids of this entity's references at this level of the class hierarchy. |
forEach(func: PropertyHandler, includeCustom?: boolean): void Inherited | ElementMultiAspect | Call a function for each property of this Entity. |
forEachProperty(func: PropertyCallback, includeCustom?: boolean): void Inherited | ElementMultiAspect | Call a function for each property of this Entity. |
getMetaData(): Promise<EntityClass> Inherited | ElementMultiAspect | query metadata for this entity class from the iModel's schema |
getReferenceIds(): EntityReferenceSet Inherited | ElementMultiAspect | Get the set of this entity's entity references, EntityReferenceSet. |
toJSON(): ElementAspectProps Inherited | ElementMultiAspect | Obtain the JSON representation of this Entity. |
is(otherClass: ): boolean Static Inherited | ElementMultiAspect | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnAspectIdArg): void Protected Static Inherited | ElementMultiAspect | Called before an ElementAspect is deleted. |
onDeleted(_arg: OnAspectIdArg): void Protected Static Inherited | ElementMultiAspect | Called after an ElementAspect was deleted. |
onInsert(arg: OnAspectPropsArg): void Protected Static Inherited | ElementMultiAspect | Called before a new ElementAspect is inserted. |
onInserted(_arg: OnAspectPropsArg): void Protected Static Inherited | ElementMultiAspect | Called after a new ElementAspect was inserted. |
onUpdate(arg: OnAspectPropsArg): void Protected Static Inherited | ElementMultiAspect | Called before an ElementAspect is updated. |
onUpdated(_arg: OnAspectPropsArg): void Protected Static Inherited | ElementMultiAspect | Called after an ElementAspect was updated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Inherited ReadOnly | string | ElementMultiAspect | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | ElementMultiAspect | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | ElementMultiAspect | The name of the BIS class associated with this class. |
element Inherited | RelatedElement | ElementMultiAspect | |
id Inherited | string | ElementMultiAspect | The Id of this Entity. |
iModel Inherited | IModelDb | ElementMultiAspect | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | ElementMultiAspect | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static Inherited | ElementMultiAspect | The Schema that defines this class. | |
schemaItemKey Accessor Inherited ReadOnly | SchemaItemKey | ElementMultiAspect | Get the item key used by the ecschema-metadata package to identify this entity class |
schemaItemKey Accessor Static Inherited ReadOnly | SchemaItemKey | ElementMultiAspect | Serves as a unique identifier for this class. Typed variant of ElementMultiAspect.classFullName. |
schemaName Accessor Inherited ReadOnly | string | ElementMultiAspect | The name of the BIS Schema that defines this class |
Defined in
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.