WeightPropertyEditor Class

Weight Property Editor registered for the "number" type name and "weight-picker" editor name. It uses the WeightEditor React component.

Extends

Methods

Name Description
constructor(): WeightPropertyEditor    

Inherited methods

Name Inherited from Description
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void Inherited PropertyEditorBase  
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> Inherited PropertyEditorBase  
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> Inherited PropertyEditorBase  

Properties

Name Type Description
reactNode Accessor ReadOnly React.ReactNode    

Inherited properties

Name Type Inherited from Description
containerHandlesBlur Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerHandlesEnter Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerHandlesEscape Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerHandlesTab Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerStopsKeydownPropagation Accessor Inherited ReadOnly boolean PropertyEditorBase  
customDataController Inherited undefined | DataController PropertyEditorBase  

Defined in

Last Updated: 30 January, 2025