WeightEditor Class

WeightEditor React component that is a property editor for picking a weight using a WeightPickerButton component

Extends

Implements

Methods

Name Description
constructor(props: PropertyEditorProps): WeightEditor    
componentDidMount(): void Called immediately after a component is mounted.  
componentWillUnmount(): void Called immediately before a component is destroyed.  
getPropertyValue(): Promise<undefined | PropertyValue>    
render(): React.JSX.Element    

Properties

Name Type Description
hasFocus Accessor ReadOnly boolean    
htmlElement Accessor ReadOnly "null" | HTMLElement    
state Readonly Readonly<WeightEditorState>    

Defined in

Last Updated: 30 January, 2025