ContextSubMenuProps Interface
Deprecated in 4.16.0. Props of deprecated ContextSubMenu component.
Properties for the ContextSubMenu component
Extends
- Omit<ContextMenuItemProps, "label">
- Omit<ContextMenuProps, "label">
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
label | string | React.ReactElement<any, string | React.JSXElementConstructor<any>> | Text/jsx to display in the list item |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
autoflip | boolean | undefined | Omit | Whether menu flips directions based on screen edge. |
badgeKind | string & { T } | "technical-preview" | "new" | "deprecated" | Omit | Specifies the kind of badge, if any, to be overlaid on the item. |
badgeType | BadgeType | undefined | Omit | Badge to be overlaid on the item. |
direction | ContextMenuDirection | undefined | Omit | Which direction the menu opens. |
disabled | boolean | ConditionalBooleanValue | Omit | Disables any onSelect calls, hover/keyboard highlighting, and grays item. |
edgeLimit | boolean | undefined | Omit | Whether menu hugs screen edge when autoflip is off. |
floating | boolean | undefined | Omit | whether menu floats on the viewport, or the page. |
hidden | boolean | ConditionalBooleanValue | Omit | Indicates whether the item is visible or hidden. |
hideIconContainer | boolean | undefined | Omit | Hide the icon container. |
hotkeySelect | boolean | undefined | Omit | Whether Hotkey press selects item, or just highlights item. |
icon | IconSpec | undefined | Omit | Icon to display in the left margin. |
iconRight | IconSpec | undefined | Omit | Icon to display in the right margin. |
isSelected | boolean | undefined | Omit | |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
onEsc | (data: any) => any | undefined | Omit | when Escape button is pressed |
onOutsideClick | (event: MouseEvent) => any | undefined | Omit | When click is registered outside of ContextMenu. |
onSelect | (event: any) => any | undefined | Omit | |
opened | boolean | Omit | Whether ContextMenu is currently opened. |
selectedIndex | number | undefined | Omit | starting menu item selected index Default: -1 |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.